Closed Bug 1645005 Opened 5 months ago Closed 3 months ago

Crash in [@ EngGetPrinterDataFileName]

Categories

(Core :: Printing: Setup, defect)

All
Windows 10
defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr68 --- wontfix
firefox77 + wontfix
firefox78 --- wontfix
firefox79 --- wontfix

People

(Reporter: philipp, Assigned: svoisen)

Details

(Keywords: crash)

Crash Data

[Tracking Requested - why for this release]:

This bug is for crash report bp-9ca679b1-12fa-4849-b606-5adcb0200611.

Top 2 frames of crashing thread:

0 gdi32full.dll EngGetPrinterDataFileName 
1 ric55mc.dll ric55mc.dll@0xecdf 

printing-related crash reports with this signature started getting submitted ten hours ago from firefox users on windows 10 across different release channels, which points to some external trigger like a windows update as a likely explanation for this spike.

those crashes account for ~4% of browser crashes on release in the past hours.

according to the dlls showing up in the stack traces of these crashes, the problem mostly appears when attempting to print on devices from ricoh, toshiba and oki.

This looks suspiciously like it might be a bug in Windows or the printer driver(s), rather than in our code.... don't know if there's any chance we can work around it?

Flags: needinfo?(jwatt)
Crash Signature: [@ EngGetPrinterDataFileName] → [@ EngGetPrinterDataFileName] [@ EngGetDriverName]

it may be caused by https://support.microsoft.com/en-us/help/4560960/windows-10-update-kb4560960 - apparently microsoft is aware of printing issues and crashes and working on a fix.

Severity: -- → S1

Relevant reddit thread:
https://www.reddit.com/r/techsupport/comments/h0ctsp/chrome_and_edge_both_quit_when_trying_to_print_a/

(Those are about Chrome and Edge crashing, but it mentions EngGetPrinterDataFileName and is probably the same underlying issue)

Also https://github.com/qgis/QGIS/issues/37290

Looks like this is a general Windows crash that affects multiple (all?) applications that can print, depending on your print drivers maybe.

Quoting https://www.reddit.com/r/techsupport/comments/h0ctsp/chrome_and_edge_both_quit_when_trying_to_print_a/ftn1vri/ :

UPDATE: it’s not just Chromium browsers. It’s all apps on the computer. Even Notepad crashes and burns.

SOLUTION: Replace your PCL 5(e) print driver with anything else; like a V4, PCL 6, PostScript, or XPS driver.

I've reached out to Microsoft on this, and confirmed that the best solution is for users to install KB 4567512.
https://support.microsoft.com/en-au/help/4567512/windows-10-update-kb4567512

Flags: needinfo?(jwatt)

I'll just assign this to myself to get it off the radar of unassigned S1 bugs, but there's really nothing to do about it right now except monitor to see that crash volume goes down as more users install KB 4567512.

Assignee: nobody → svoisen

Microsoft update related, affects other apps as well. Crash rate is trending down.

Closed as INVALID since it's not a Firefox bug (other programs similarly affected as noted above), and Microsoft has confirmed that it's their bug & they've issued a fix.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.