crash getting help at netcenter

VERIFIED DUPLICATE of bug 1646

Status

SeaMonkey
General
P3
critical
VERIFIED DUPLICATE of bug 1646
18 years ago
13 years ago

People

(Reporter: Mike Pinkerton (not reading bugmail), Assigned: don)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
go to my.netscape.com
click the "sign in" button.
enter garbage, you'll get an error screen.
click the "help" icon down at the bottom of the page.

boom.

PowerPC unmapped memory exception at 60000000
 Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  09C4B5F4
  0A81FC40    PPC  09C47DE4  main+0013C
  0A81FBD0    PPC  09C47984  main1(int, char**)+00640
  0A81FAC0    PPC  0E11D2D0  nsAppShellService::Run()+00020
  0A81FA80    PPC  0D898DB0  nsAppShell::Run()+00050
  0A81FA00    PPC  0D899B44  nsMacMessagePump::DoMessagePump()+00044
  0A81F9B0    PPC  0D899E4C  nsMacMessagePump::DispatchEvent(int, EventRecord*)+
00188
  0A81F960    PPC  0E2A3D84  Repeater::DoRepeaters(const EventRecord&)+00034
  0A81F920    PPC  0D876A94  nsMacNSPREventQueueHandler::RepeatAction(const
EventRecord&)+000
2C
  0A81F8E0    PPC  0DF7FBE8  nsEventQueueServiceImpl::ProcessEvents()+0002C
  0A81F8A0    PPC  0DF7AE30  nsHashtable::Enumerate(int (*)(nsHashKey*, void*,
void*), void*)
+0003C
  0A81F860    PPC  0E00FEFC  PL_HashTableEnumerateEntries+00060
  0A81F7F0    PPC  0DF7A670  _hashEnumerate(PLHashEntry*, int, void*)+00030
  0A81F7B0    PPC  0DF7FB48  EventDispatchingFunc(nsHashKey*, void*, void*)+0003C
  0A81F770    PPC  0DF97EF8  nsEventQueueImpl::ProcessPendingEvents()+00018
  0A81F730    PPC  0E00EDC8  PL_ProcessPendingEvents+00078
  0A81F6E0    PPC  0E00EEFC  PL_HandleEvent+0004C
  0A81F6A0    PPC  0E27AF24  HandlePLEvent(OnLinkClickEvent*)+00014
  0A81F660    PPC  0E27AFBC  OnLinkClickEvent::HandleEvent()+0004C
  0A81F620    PPC  0E27B940  nsWebShell::HandleLinkClickEvent(nsIContent*,
nsLinkVerb, const
unsigned short*, const unsigned short*, nsIInputStream*)+000D4
  0A81F540    PPC  0E275EAC  nsWebShell::LoadURL(const unsigned short*,
nsIInputStream*, int,
 unsigned int, unsigned int, nsISupports*, const unsigned short*)+00098
  0A81F4F0    PPC  0E278570  nsWebShell::LoadURL(const unsigned short*, const
char*, nsIInput
Stream*, int, unsigned int, unsigned int, nsISupports*, const unsigned short*)+
00770
  0A81F080    PPC  0E277D44  nsWebShell::LoadURI(nsIURI*, const char*,
nsIInputStream*, int,
unsigned int, unsigned int, nsISupports*, const unsigned short*)+0041C
  0A81EEA0    PPC  0E276B40  nsWebShell::DoLoadURL(nsIURI*, const char*,
nsIInputStream*, uns
igned int, unsigned int, const unsigned short*)+008AC
  0A81EC10    PPC  0E26841C  nsDocLoaderImpl::LoadDocument(nsIURI*, const char*,
nsIContentVi
ewerContainer*, nsIInputStream*, nsISupports*, unsigned int, unsigned int, const
unsigned sho
rt*)+00170
  0A81EBA0    PPC  0E26B644  nsDocumentBindInfo::Bind(nsIURI*, nsILoadGroup*,
nsIInputStream*
, const unsigned short*)+0015C
  0A81EAC0    PPC  0E26BF20
 Closing log

Updated

18 years ago

Comment 1

18 years ago
Bug also occurs with 1999-10-13-13-M11 on Windows NT 4.0 SP5.
You can also go directly to http://ureg.netscape.com/iiop/UReg2/login/loginform
and click "Help". Adding that in URL field.
Here is the NT stack dump:
function: NSGetFactory
        608b2549 5b               pop     ebx
        608b254a 8d4d0c           lea     ecx,[ebp+0xc]
ss:0148e012=????????
        608b254d e858520000       call    608b77aa
        608b2552 ff75fc           push    dword ptr [ebp-0x4]
ss:0148e012=????????
        608b2555 8b4f18           mov     ecx,[edi+0x18]
ds:0b8f54f6=????????
        608b2558 e8f6fbffff       call    NSGetFactory+0x93d (608b2153)
        608b255d 8b45fc           mov     eax,[ebp-0x4]
ss:0148e012=????????
        608b2560 57               push    edi
        608b2561 56               push    esi
        608b2562 6aff             push    0xff
FAULT ->608b2564 8b08             mov     ecx,[eax]
ds:00000000=????????
        608b2566 56               push    esi
        608b2567 50               push    eax
        608b2568 ff512c           call    dword ptr [ecx+0x2c]
ds:0b55aa6e=????????
        608b256b 8d4dfc           lea     ecx,[ebp-0x4]
ss:0148e012=????????
        608b256e 8bf0             mov     esi,eax
        608b2570 e835520000       call    608b77aa
        608b2575 8d4df8           lea     ecx,[ebp-0x8]
ss:0148e012=????????
        608b2578 e82d520000       call    608b77aa
        608b257d 8d4df4           lea     ecx,[ebp-0xc]
ss:0148e012=????????
        608b2580 e825520000       call    608b77aa
        608b2585 8bc6             mov     eax,esi

*----> Stack Back Trace <----*

FramePtr ReturnAd Param#1  Param#2  Param#3  Param#4  Function Name
0012f60c 608b1cb7 0a598cc0 00000000 00000000 0a598ac0 gkweb!NSGetFactory
0012f62c 608b4c3f 0a1fc050 0a598cc0 608ba514 0a1fcc10 gkweb!NSGetFactory
0012f738 608b4f96 0a598cc0 608ba514 00000000 00000000
gkweb!NS_TotalWebShellsInExistence
0012f8b8 608b5457 0a598cf0 0a598cc0 608ba514 00000000
gkweb!NS_TotalWebShellsInExistence
0012fca4 608b47cc 0012fc98 0012fc8c 608ba514 00000000
gkweb!NS_TotalWebShellsInExistence
0012fcd4 608b5fb0 0a1fcc10 0a56bc80 00000000 00000001
gkweb!NS_TotalWebShellsInExistence
0012fd9c 608b5d1e 0a27e36c 00000000 0a56bc80 60b14008
gkweb!NS_TotalWebShellsInExistence
0012fdbc 60ad194e 0a56bb60 00000004 0a56bb60 60ad18dd
gkweb!NS_TotalWebShellsInExistence  (FPO: [0,0,2])
0012fdcc 60ad18dd 0a56bb60 006c4548 0012fe50 00000000 plds3!PL_HandleEvent
(FPO: [1,0,2])
0012fe00 60ad1b78 00459cd0 77e71820 007806e6 0000c0ac
plds3!PL_ProcessPendingEvents  (FPO: [1,8,3])
0012fe08 77e71820 007806e6 0000c0ac 00000000 00459cd0
plds3!PL_IsQueueOnCurrentThread  (FPO: [4,0,0])
0012fe6c 6001191d 00480620 004013f0 00458040 00000350 user32!TranslateMessageEx
0012fe74 004013f0 00458040 00000350 00410010 00000000 appshell!<nosymbols>
(FPO: [1,0,0])
0012ff10 004010ce 00000001 00458040 00000000 00000000 mozilla!<nosymbols>
0012ff4c 004021eb 00000001 00410010 00410eb0 00404000 mozilla!<nosymbols>
0012ffc0 77f1ba06 00000350 01ef5c98 7ffdf000 c0000005 mozilla!<nosymbols>
0012fff0 00000000 00402108 00000000 000000b0 00000100
kernel32!GetProcessPriorityBoost
00000000 00000000 00000000 00000000 00000000 00000000 mozilla!<nosymbols>

Updated

18 years ago
OS: Mac System 8.5 → All
Hardware: Macintosh → All
Whiteboard: [MAKINGTEST] mats@symsoft.se

Comment 2

18 years ago
Bug also occurs in Viewer (built Oct 8) on Sun/Solaris 2.6/sparc.
Changing Platform/OS to All/All.
This is the stack dump:

t@1 (l@1) terminated by signal SEGV (no mapping at the fault address)
(dbx) where
current thread: t@1
=>[1] DoLoadURL__10nsWebShellP6nsIURIPCcP14nsIInputStreamUiUiPCUs(0x4ce200,
0x4db700, 0xef0679f8, 0x0, 0x0, 0x0), at 0xef061fc0
  [2]
LoadURI__10nsWebShellP6nsIURIPCcP14nsIInputStreamiUiUiP11nsISupportsPCUs(0x0,
0x4db700, 0xef0679f8, 0x0, 0xef0e4628, 0x0), at 0xef0622f8
  [3]
LoadURL__10nsWebShellPCUsPCcP14nsIInputStreamiUiUiP11nsISupportsT1(0x4ce200,
0xef0e4ea4, 0xef0679f8, 0x0, 0x1, 0x0), at 0xef062aac
  [4] LoadURL__10nsWebShellPCUsP14nsIInputStreamiUiUiP11nsISupportsT1(0x4ce200,
0xef0e4ea4, 0x0, 0x1, 0x0, 0x0), at 0xef061500
  [5] OpenInternal__16GlobalWindowImplP9JSContextPlUiiPP12nsIDOMWindow(0x311980,
0x249e00, 0x35c064, 0x3, 0x0, 0xef0e5014), at 0xee1b3d44
  [6] Open__16GlobalWindowImplP9JSContextPlUiPP12nsIDOMWindow(0x311980,
0x249e00, 0x35c064, 0x3, 0xef0e5014, 0xee1b36b0), at 0xee1b36c8
  [7] 0xee1abcbc(0x249e00, 0x3412c8, 0x3, 0x35c064, 0xef0e50ec, 0x35c064), at
0xee1abcbb
  [8] js_Invoke(0x249e00, 0x3, 0x0, 0x3412c8, 0x0, 0xee1abbb0), at 0xef70bc04
  [9] js_Interpret(0x249e00, 0xef0e533c, 0x0, 0x249e00, 0x3f1b65, 0xef0e5340),
at 0xef711db8
  [10] js_Invoke(0x249e00, 0x1, 0x0, 0x3412c8, 0x0, 0x0), at 0xef70bc58
  [11] js_Interpret(0x249e00, 0xef0e56f0, 0x36c0f0, 0x249e00, 0x451073,
0xef0e5580), at 0xef711db8
  [12] js_Execute(0x249e00, 0x3412c8, 0x451040, 0x0, 0x0, 0x0), at 0xef70bf9c
  [13] JS_EvaluateUCScriptForPrincipals(0xef0e56f0, 0x3412c8, 0x451040,
0x264b00, 0x34, 0x0), at 0xef6f2110
  [14]
EvaluateString__11nsJSContextRC8nsStringPvP12nsIPrincipalPCcUiR8nsStringPi(0x320
240, 0xef0e57d0, 0x0, 0x0, 0x0, 0x0), at 0xee1a5b70
  [15] Eval__15nsJSInputStream(0x405d80, 0x0, 0x46c780, 0xef0e5d98, 0x2431a0,
0xef658dd0), at 0xedd22868
  [16] Available__15nsJSInputStreamPUi(0x405d80, 0xef0e5adc, 0x405d80,
0xedd226e0, 0xef6591e8, 0xee7d0310), at 0xedd226f4
  [17] Process__15nsFileTransport(0x460f00, 0x0, 0x22df80, 0xef6447cc,
0xef7ec9c0, 0x228e00), at 0xee7d60a4
  [18] Run__15nsFileTransport(0x460f00, 0xee7d5dd8, 0x0, 0x0, 0x0, 0x0), at
0xee7d5de4
  [19] Run__20nsThreadPoolRunnable(0x2431e0, 0xef667c28, 0x2431e0, 0xef0e5d98,
0x10a3e0, 0x0), at 0xef667c68
  [20] Main__8nsThreadPv(0x243200, 0xef666bc8, 0x0, 0x0, 0x0, 0x0), at
0xef666be4
  [21] 0xef5b31a0(0x48c, 0xef0e5e38, 0x0, 0x0, 0x0, 0x0), at 0xef5b319f
(dbx) quit

Comment 3

18 years ago
Created attachment 2184 [details]
testcase

Updated

18 years ago
Whiteboard: [MAKINGTEST] mats@symsoft.se → [TESTCASE]

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
*** This bug has been marked as a duplicate of 1646 ***

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
[bugday] the two bugs are the same javascript URL problem. marking verified.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.