Closed Bug 1645159 Opened 1 year ago Closed 1 year ago

Windows 10 crash on resume from hibernation due to Firefox

Categories

(Core :: Widget, defect)

77 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ole.traupe, Unassigned)

Details

Attachments

(3 files, 1 obsolete file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

After e.g. watching Youtube vids with Firefox and going into hibernation, when resuming my Windows 10 it would crash immediately before the login screen would appear. The screen stays black and I can only hard reset. This is on a Dell XPS13 7390 with Intel IGP.

I did the following to try to resolve the issue:

  • update every driver
  • removed previously installed Windows updates
  • sfc /scannow
  • chkdsk /F C:
  • Dell pre-boot diagnose
  • disconnected every USB device and varied the connection of the USB-C charger
  • re-flashing the Bios
  • ... (a couple of things I probably forgot)

Then I went on to think about running software. I also remembered a web article about Firefox getting more Webrender support.

First I closed Firefox before Hibernation. The crash did not re-occur.
Then I disabled Webrender (about:config -> gfx.webrender.compositor = false), restarted Firefox, and left Firefox on before Hibernation. The crash did not re-occur. It seems, Firefox Webrender is the culprit.

Actual results:

Windows 10 crash on resume from Hibernation right before the login prompt would appear.

Expected results:

Login prompt/screen appears and I can login and return to Windows operations.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Graphics: WebRender
Product: Firefox → Core

Can you attach the contents of about:support as a text file please?

Flags: needinfo?(ole.traupe)
Attached file about.support (obsolete) —

contents of about:support as plain text, with webrender enabled

Flags: needinfo?(ole.traupe)
Attached file about.support.english

and here it is in english

contents of about:support as plain text; with webrender enabled

Attachment #9156068 - Attachment is obsolete: true

Can you flip gfx.webrender.compositor to false again, restart Firefox and send me the about:support again?

Flags: needinfo?(ole.traupe)
Flags: needinfo?(ole.traupe)

Rares, can you take a stab at reproducing this?

Flags: needinfo?(rares.doghi)

Glenn have you seen anything similar with your machine with an Intel 620? Not sure if that is running Windows or not.

Flags: needinfo?(gwatson)

Is there anything unique or interesting about your set up? Are you using any external monitors or using a docking station, perhaps? Any further information would be helpful as we try to reproduce this issue. Thank you!

Flags: needinfo?(ole.traupe)

I am using the USB-C charger that came with it. And sometimes, but not always, a USB-C to USB-A convertor for the dongle for my wireless audio headset, and that dongle, of course. But the issue occurred without this convertor/dongle attachmed, I'm sure.

No further peripherals connected.

Flags: needinfo?(ole.traupe)

I tried to reproduce this issue on a Windows 10 machine with Intel HD 620 but without success, I tried opening a few youtube videos in different tabs before making the machine go into hibernation but no crashes occured after coming out of hibernation, for windows or Firefox.

I also tried downgrading the Intel Driver to 26.20.100.7263 from the latest one 26.20.100.7812, I was still unable to reproduce this issue.

Flags: needinfo?(rares.doghi)

Thank you for the effort you have put into diagnosing this!

It would be interesting to see if you can repro this in an older release: http://ftp.mozilla.org/pub/firefox/releases/ (also with WebRender enabled) just to see if it always happens for you with WebRender.

And does this always happen when trying to resume after hibernation or does it only seem to happen after specifically watching YouTube videos?

Flags: needinfo?(ole.traupe)

It does not happen 100% reliably, which made it so hard to diagnose. And it also happened, while I was testing this, that I basically just restarted the machine, fired up Firefox (currently 4 windows with a bunch of tabs, one of the active ones might have been Youtube, not sure) and sent it to hibernation. And on resume Windows hung again.

If I install an older release over the existing one, will it harm any of my open tabs or other browser data?

Flags: needinfo?(ole.traupe)

Weird, I am currently trying to reproduce the hang again. And I seemingly can't. Meanwhile I am on 77.0.1. I believe I was on 77.0.0 when I first looked the Firefox version up during debugging.

I'll come back here when the thing returns.

So the issue quickly returned. Unfortunately, now it also has happened 2 times with webrender enabled. Seems to be more rare, though. And I never got the hang on resume with Firefox being shut down before going hibernate. I tested this many times.

I am not sure how to proceed here. At the very least I would need to remove the term "WebRender" from the bug title.

Could you please advise me what to do best in terms of this bug report? Many thanks!

I've adjusted the bug title. You should also report the bug to Microsoft on feedback hub and post the url for it here.

Component: Graphics: WebRender → Graphics
Summary: Windows 10 crash on resume from hibernation due to Firefox Webrender → Windows 10 crash on resume from hibernation due to Firefox

I don't want to use the feedback hub. I am using a local Windows account. If I use the feedback hub, I have to login with a MS account and during that process MS will connect this account with every activity I will perform on may PC in the future. MS will even connect my biometric features with my MS account (the login screen just stated that, explicity). I am using a local account for a reason.

Sorry, but I cannot do that.

I've not seen anything like that on my 7390 machine (although, I only boot into Windows occasionally on that machine, so it might be unlikely for me to see it).

If you open the Event Viewer [1] can you find any Error event logs from when Firefox has crashed? (it can sometimes be tricky to find them, as the system records a lot of different event types).

If there are any Firefox crash entries in there, they might contain some relevant information (such as DLL the crash occurred in) that could give us some clues to which piece of code is crashing.

[1] https://www.howtogeek.com/123646/htg-explains-what-the-windows-event-viewer-is-and-how-you-can-use-it/

Flags: needinfo?(gwatson)

I am actually quite familiar with the event viewer. During my initial (~10 h of work) trouble shooting listed above, I consulted the event log and found an error for my Killer wireless network card right at the time of crash. I updated the driver and the issue persisted. A while later I removed any installed Killer driver and software with their driver removal tool and let Windows deal with the driver installation. I never saw that Killer error in the event log again.

Unfortunately, I haven't seen any other error either. Particularly none associated with Firefox. It seems like the system stops responding altogether.

When I manage to produce my next hang I'll try to export the event logs (System and Application) after reaching Windows again. I'll post them here.

It seems uncertain if this is related to Graphics since it seems to happen with and without WebRender. Moving to a different component for now to see if we can get better support for troubleshooting

Component: Graphics → Widget

System event log with all entries since resume (including hang/crash and reboot).

Now there is an error event regarding Wi-Fi Direct device. However, MS knowledge base says it can be ignored if resuming from sleep/hibernation.

The Application event log is empty up until the reboot.

No longer blocks: gfx-triage

The severity field is not set for this bug.
:jimm, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jmathies)

Please don't spend any more effort on this. It might as well be an add-on that has gone rogue. I haven't installed any new add-on for quite some time (way before the hang first occurred). But since I disabled some of them a couple of days ago (rather randomly on a hunch), the hang hasn't returned. Hard to say whether it is gone and which add-on it might be, as sometimes the hang is hard to reproduce.

I have disabled the following add-ons:

  • "BetterTTV" [haven't visited Twitch in ages though]
  • "Duplicates Tab Closer" [used quite frequently, always active in the background]
  • "Tab Reloader (page auto refresh)" [haven't used for a while]
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Flags: needinfo?(jmathies)
Resolution: --- → WORKSFORME

It seems to have been the "Tab Reloader (page auto refresh)", an addon actually recommended by Firefox. With only this one disabled, I haven't seen the issue again.

You need to log in before you can comment on or make changes to this bug.