Mozilla ignores command line start up parameters

VERIFIED WORKSFORME

Status

SeaMonkey
General
--
major
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Harvey Savage, Assigned: asa)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020813
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1b) Gecko/20020813

Mozilla ignores command line parameters e.g. -mail -nosplash -quiet -height
-width, probably others.  

I have downloaded and installed the last 2 betas, 2002082404 and 2002082504.
Both issues ignore command line parmeters that should be available for startup.

Both issues will not allow me to log on to Bugzilla to file a bug.  Out of
necessity I must uninstall and reinstall an older version to file a bug or use
command line parameters to start and display as I want

Reproducible: Always

Steps to Reproduce:
1.Install new version.
2.startup with shortcut - c:\mozilla\mozilla.exe -quiet -height 700 -width 800
3.Mozilla starts but, Parameters have no effect on the startup window size.
4.change to  -quiet -height 400 -width 500, still no effect. 
5
Actual Results:  
Command line parameters have no effect, must install an older version to regain
parameter control.

Expected Results:  
Mozilla should have adjusted the start up window to conform to the new
parameters,   -quiet -height 400 -width 500.

In the aforementioned, latest issues, after initially starting the email client
you cannot get the email client to start up again.  It loads, at least partially
into memory, Ctrl+Alt+Delete shows Mozilla as a running application but it never
fully loads, or never appears on the screen and you cannot download or view email.

If you think this behaviour should be reported with a different bug report I
would be glad to do so.

Comment 1

16 years ago
WFM 2002082304/winXP

Reporter, did you try a clean reinstall?

Summary: Mozilla ignores command line start up parameters → Mozilla ignores command line start up parameters

Comment 2

16 years ago
> I used the Uninstall program that comes with Mozilla.  That has always
> been adequate when the new beta doesn't have faults.

Time to time, Mozilla gains a "critical mass" of changes that make it
incompatible with its own internal config files from previous betas. In that
case, the following sequence of actions is recommended:

1) Uninstall Mozilla using its own uninstaller
2) Completely erase the contents of Mozilla directorty (c:\Program
Files\mozilla.org\Mozilla by default); you may leave Plugins directory intact
though.
3) Install new version.

This most likely will solve your problem.

Thanks for your help in testing Mozilla!
Severity: blocker → major

Comment 3

16 years ago
From personal email:

hsavage <hsavage@pobox.com> wrote:

> I did as you suggested, the 3 steps above, to no avail.  Mozilla still
> performs exactly the same when I install the new version. BTW, the
> version I'm trying is 2002082508.

> When the newer versions don't work right, and they haven't since about
> version 2002081408, I always reinstall the standby I have, version
> 2002081308.


Might be highly specific win98 problem. Somebody with win98, please try
reproducing? My win98 HDD is dead until I get a replacement late next week.
Whiteboard: need person with win98 to confirm this bug

Comment 4

16 years ago
Same behaviour on Win2k.  Also, once mail starts up and then you close it, it
will never come back.

Comment 5

16 years ago
I use Win98 and have the previously described problem. After I did a clean
reinstall as described above, I thought it had gone away. It seems to be
intermittent, though (or affected by something I didn't notice changing.) I've
been able to open new window, Mail, files and so on briefly, but just ten
seconds ago when I tried to open a local file (done with the -url switch, as I'm
sure you know) it failed to work -- it just switched to the most recently active
Mozilla window.

Comment 6

16 years ago
Oh, by the way, the buttons on the bottom bar work just fine.

Comment 7

16 years ago
WORKSFORME win98se/2002090404...

Reporters: please try to figure out what software that doesn't ship with Windows
are you using? Might be some antivirus, firewall, etc that causes interference.
Whiteboard: need person with win98 to confirm this bug

Comment 8

16 years ago
It might well be the quick launch program that's doing this, as having disabled
quick launch and restarted, now command line params work as normal. FWIW, I'm
using ZoneAlarm standard and Norton Anti-Fish (OEM) 5.something.

Comment 9

16 years ago
Harvey Savage, please check whether disabling Quick Launch fixes this issue per
comment #8... this might explain the erratic behavior.
(Reporter)

Comment 10

16 years ago
I had this problem before the big fiasco with Mozilla not installing.  It has
gotten much better with the latest issues.

I haven't used quicklaunch for quite a while, I tried it for a short time and
under certain conditions it would cause Mozilla not to load and other times it
caused lockups.

I stopped using it.

harvey r. savage
hsavage@pobox.com

Comment 11

16 years ago
->WFM per comment #10
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 12

16 years ago
v.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.