Closed Bug 1645600 Opened 2 years ago Closed 2 years ago

Crash in [@ wl_proxy_marshal_array_constructor_versioned | <name omitted> | mozilla::widget::WindowBackBuffer::Attach]

Categories

(Core :: Widget: Gtk, defect)

77 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED DUPLICATE of bug 1641778
Tracking Status
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed

People

(Reporter: matt.fagnani, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-b708d956-c0b3-4daf-aeba-19c430200613.

Top 10 frames of crashing thread:

0 libwayland-client.so.0 wl_proxy_marshal_array_constructor_versioned src/wayland-client.c:734
1 libwayland-client.so.0 <name omitted> src/wayland-client.c:797
2 libxul.so mozilla::widget::WindowBackBuffer::Attach /builddir/build/BUILD/firefox-77.0.1/widget/gtk/WindowSurfaceWayland.cpp:375
3 libxul.so mozilla::widget::WindowSurfaceWayland::CommitWaylandBuffer /builddir/build/BUILD/firefox-77.0.1/widget/gtk/WindowSurfaceWayland.cpp:1116
4 libxul.so mozilla::layers::BasicCompositor::EndRemoteDrawing /builddir/build/BUILD/firefox-77.0.1/gfx/layers/basic/BasicCompositor.cpp:1169
5 libxul.so mozilla::layers::BasicCompositor::EndFrame /builddir/build/BUILD/firefox-77.0.1/gfx/layers/basic/BasicCompositor.cpp:1102
6 libxul.so mozilla::layers::LayerManagerComposite::Render /builddir/build/BUILD/firefox-77.0.1/gfx/layers/composite/LayerManagerComposite.cpp:1266
7 libxul.so mozilla::layers::LayerManagerComposite::UpdateAndRender /builddir/build/BUILD/firefox-77.0.1/gfx/layers/composite/LayerManagerComposite.cpp:645
8 libxul.so mozilla::layers::LayerManagerComposite::EndTransaction /builddir/build/BUILD/firefox-77.0.1/gfx/layers/composite/LayerManagerComposite.cpp:534
9 libxul.so mozilla::layers::CompositorBridgeParent::CompositeToTarget /builddir/build/BUILD/firefox-77.0.1/gfx/layers/ipc/CompositorBridgeParent.cpp:1042

I was using Firefox 77.0.1 on Wayland with Webrender and GPU acceleration enabled in Plasma 5.18.5 in Fedora Rawhide. I went to https://koji.fedoraproject.org I clicked on Builds and selected rpm from the Type box. Firefox had a segmentation fault in wl_proxy_marshal_array_constructor_versioned at wayland-client.c:734 in libwayland-client-1.18.0-1.fc33. I've seen Firefox crash with this trace once, though Firefox on Wayland has crashed occasionally without crash reports being saved.

Blocks: wayland
Crash Signature: [@ wl_proxy_marshal_array_constructor_versioned | <name omitted> | mozilla::widget::WindowBackBuffer::Attach] → [@ wl_proxy_marshal_array_constructor_versioned | <name omitted> | mozilla::widget::WindowBackBuffer::Attach] [@ wl_proxy_marshal_array_constructor_versioned | wl_proxy_marshal | mozilla::widget::WindowBackBuffer::Attach] [@ wl_proxy_marshal_array_const…
Depends on: 1636072
Keywords: crash
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Should be fixed by Bug 1641778.

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1641778
You need to log in before you can comment on or make changes to this bug.