Closed Bug 1645731 Opened 4 months ago Closed 4 months ago

Autocomplete panel exposed as an alert for accessibility

Categories

(DevTools :: Console, defect)

defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
Firefox 79
Tracking Status
firefox79 --- fixed

People

(Reporter: Jamie, Assigned: Jamie)

Details

(Keywords: access, Whiteboard: [access-s2])

Attachments

(1 file)

STR (with NVDA):

  1. Open the Dev Tools Console.
  2. Type just "H" (capital h). Don't do anything else.
    • Expected: No lag.
    • Actual: NVDA reports "alert", then there's a ~7 second lag before you can do anything else with NVDA.

This occurs because the panel for the autocomplete popup is getting the alert role, so NVDA tries to walk its descendants to report the alert. There's explicit code to prevent this, but it's now acting on the wrong node (a div instead of the XUL panel).

This is a regression, but I don't know when it happened.

Impact: This makes the console pretty unusable for screen reader users.

Keywords: access
Whiteboard: [access-s2]

There was already code to do this, but it was acting on a div instead of the XUL panel.

Pushed by mzehe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/12ef06d0d76b
Don't expose the autocomplete popup panel as an alert for accessibility. r=nchevobbe
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79
QA Whiteboard: [qa-79b-p2]
You need to log in before you can comment on or make changes to this bug.