Closed Bug 1645768 Opened 4 months ago Closed 3 months ago

Please add 'See Also' support for GitLab

Categories

(bugzilla.mozilla.org :: Bug Creation/Editing, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: mgorny, Assigned: dkl)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

46 bytes, text/x-github-pull-request
Details | Review

There is a growing number of projects using GitLab for their contributions. However, it seems that even with MoreBugUrl extension GitLab merge requests URL are not accepted in 'See also'. Could it be extended for that, please?

GitLab issue and merge request URLs follow the following patterns, respectively:

https://<domain>[/<relative_url>]/<group>/<project>/-/issues/<number>
https://<domain>[/<relative_url>]/<group>/<project>/-/merge_requests/<number>

The 'issues' part seems to be handled already by the support for some other backend, however 'merge_requests' are not. I suspect it would be reasonable to match them via path ending with '/-/merge_requests/[0-9]+'.

Examples:

https://invent.kde.org/multimedia/kdenlive/-/issues/724
https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/82

Disclaimer: I've tested it only on 5.0.6 but grepped git master for 'merge_requests'.

Assignee: create-and-change → dkl
Status: UNCONFIRMED → ASSIGNED
Component: Creating/Changing Bugs → Bug Creation/Editing
Ever confirmed: true
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED

This change is live now.

I'm sorry but I'm confused. Does that mean that this feature will only be available on BMO but not in 'regular' Bugzilla code to be consumed downstream?

(In reply to Michał Górny from comment #4)

I'm sorry but I'm confused. Does that mean that this feature will only be available on BMO but not in 'regular' Bugzilla code to be consumed downstream?

Yes, upstream would need to cherry pick the patch from our repository.

You need to log in before you can comment on or make changes to this bug.