Closed Bug 1645810 Opened 2 years ago Closed 2 years ago

.local domain urls are searched but not resolved

Categories

(Firefox :: Address Bar, defect)

77 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1634650

People

(Reporter: dev, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

open internal url e.g. site.domain.local

Actual results:

site.domain.local is seached instead of resolved.

Expected results:

site.domain.local should be resolved and opened.

(In reply to Joule from comment #0)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

open internal url e.g. site.domain.local

Actual results:

site.domain.local is seached instead of resolved.

Expected results:

site.domain.local should be resolved and opened.

Have to add when site.domain.local is typed into address bar.

Should also add expected should be when i type site.domain.local/ -> url is being resolved not searched
site.domain.local -> url is being searched.

This works on chromium latest build, chromium-edge, opera, palemoon

Don't know what firefox changed recently.

also just tested with the same behavior on clean profile using start firefox -profile <path> -no-remote -new-instance

Setting a component for this issue in order to get the dev team involved.
If you feel it's an incorrect one please feel free to change it to a more appropriate one.

Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1634650
Component: DOM: Core & HTML → Address Bar
Product: Core → Firefox
You need to log in before you can comment on or make changes to this bug.