Closed Bug 1645887 Opened 9 months ago Closed 8 months ago

Pop-up menu items on debugger are swapped (?)

Categories

(DevTools :: Debugger, defect)

77 Branch
defect

Tracking

(firefox80 fixed)

RESOLVED FIXED
Firefox 80
Tracking Status
firefox80 --- fixed

People

(Reporter: aldo, Assigned: kyleknaggs, NeedInfo)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:77.0) Gecko/20100101 Firefox/77.0

Steps to reproduce:

  1. Enable dev tools on an existing page
  2. Click on "Debugger"
  3. Select a line from the panel and right-click anywhere on the panel
  4. Options 3 and 4 are usually enabled. One is "Copy to clipboard", the other is "Copy source text"

Actual results:

Option 3 should have copied the selected text. Option 4 should copy all text, but see my comments below.

Expected results:

The menu labels are confusing and I think they are swapped.
"Copy to clipboard" should copy what's selected, not the entire source. If nothing is selected it should be grayed out (disabled).

Copy source text (one would argue no one really needs this) should be renamed "Copy all text" or removed. Also, as you can reason for yourself, the labels are swapped.

What is "Copy source URI" and who needs it? Please consider removing this as well.

Please do not be offended by my comments , dev tool is confusing to use because of poor naming and cluttered functionality that seem to not be useful. Did anyone study the use cases and vet them before deciding what to implement? What is your process as a group to vet before implementing? Just saying... not hating. Peace out.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → Debugger

I agree with aldo that the naming and the functionality of the Editor's context menu can certainly be improved and I think it would be wise for us to consider his suggestions. I would like to be assigned to this issue. My proposal would be to:

  1. Rename Option 3 from “Copy to clipboard” to “Copy selected text”.
  2. Rename Option 4 from “Copy source text” to “Copy all text from source”.
  3. Disable Option 3 unless the user has selected text in the Editor.
  4. Enable Option 4 at all times.
  5. Swap the functionality of Option 3 and Option 4 so that Option 3 copies the text that has been selected by the user and Option 4 copies all of the text in the source.

The severity field is not set for this bug.
:jlast, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(jlaster)

Fixes the menu items in the Editor and Tab context menu so that:

  1. 'Copy to clipboard' => Copies the text that has been selected by a user to the clipboard.
  2. 'Copy source text' => Copies all of the text from a source to the clipboard.
Assignee: nobody → kyleknaggs
Pushed by dwalsh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b74a89903c5a
Fix text copied by 'Copy to clipboard' and 'Copy source text' context menu items r=davidwalsh
Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
QA Whiteboard: [qa-80b-p2]
You need to log in before you can comment on or make changes to this bug.