Closed Bug 1646092 Opened 3 months ago Closed 3 months ago

ICE never nominates/selects on calls with Chrome with RTX enabled and only a microphone present

Categories

(Core :: WebRTC, defect, P3)

defect

Tracking

()

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: dminor, Assigned: dminor)

Details

Attachments

(3 files)

I ran into this while testing Bug 1644577, on a Firefox <-> Chrome call, using https://whereby.com/dminor, with RTX enabled and only a microphone as an input, ICE would consistently succeed, but never nominate or select a candidate. Using Wireshark, I see no RTP traffic at all.

Firefox <-> Firefox and Firefox <-> Chrome with RTX disabled or camera+microphone present all succeed.

I have no idea what is going on here, but it will be very important to test both combinations of:

  • Firefox enters the room first followed by Chrome
  • Chrome enters the room first followed by Firefox
    because in these two scenarios the offerer changes and that (normally) also changes which browser gets be the ICE controller. The result of the above combinations will tell you if this is a Firefox or a Chrome bug.

I am not having any luck reproducing this. Does this only happen on devices that do not have a camera? Can you attach about:webrtc and a packet capture here?

Attached file about:webrtc

This only reproduces on devices without a camera. I've attached about:webrtc and a wireshark capture for the case where Chrome is already in the room and Firefox joins. If Firefox is already in the room and Chrome joins, I don't even see a setRemoteDescription.

Byron suspects that Chrome is having problems with the SDP we're generating in this case. I'm having a look.

Assignee: nobody → dminor

Chrome will not accept sdp with ssrc-group:FID on recvonly msections, causing
calls to fail to be established between Firefox and Chrome when only a
microphone is present on the Firefox side.

Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/35dcd6ad89c6
Do not add ssrc-group to sdp on recvonly msections; r=bwc

Sorry, forgot to run the gtests locally before pushing this. Try job here: https://treeherder.mozilla.org/#/jobs?repo=try&revision=02b5ed13aa09de4d4ff78610e606047dad03d5eb.

Flags: needinfo?(dminor)
Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1600f8f780e4
Do not add ssrc-group to sdp on recvonly msections; r=bwc
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.