Closed Bug 1646267 Opened 4 months ago Closed 3 months ago

Extraneous reporting of "list" by screen readers in Dev Tools autocompletes

Categories

(DevTools :: Shared Components, defect)

defect

Tracking

(firefox-esr68 wontfix, firefox-esr78 wontfix, firefox77 wontfix, firefox78 wontfix, firefox79 fixed)

RESOLVED FIXED
Firefox 79
Tracking Status
firefox-esr68 --- wontfix
firefox-esr78 --- wontfix
firefox77 --- wontfix
firefox78 --- wontfix
firefox79 --- fixed

People

(Reporter: Jamie, Assigned: Jamie)

References

(Regression)

Details

(Keywords: access, regression, Whiteboard: [access-s3])

Attachments

(1 file)

STR (with the NVDA screen reader):

  1. Open the Dev Tools console.
  2. Type just the letter "a".
    • Observe: NVDA says, "list, addEventListener..."
  3. Press down arrow.
    • Expected: NVDA should say, "alert..."
    • Actual: NVDA says, "list, alert..."

"list" gets spoken every time you use the arrow keys to move through the items. This makes for a very inefficient, annoying experience for screen reader users.

The reason is that the list clone is rebuilt completely every time aria-activedescendant is set. Instead, the list clone should only be rebuilt when the main list changes.

This behaviour was introduced in bug 1285591, though that in turn was to fix a11y which got completely broken in bug 1266456.

Previously, the list clone was completely replaced every time aria-activedescendant was set.
This caused screen readers to extraneously report this as a new list every time the user cursored to a different item, even if the items hadn't changed.

Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0ab07b5b4a28
In Dev Tools autocompletes, Only rebuild the list a11y clone when the main list changes. r=nchevobbe
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

Is this something we'd want to fix on ESR78? I guess we've already shipped a couple ESRs with this bug anyway, but the fix looks pretty small anyway.

Flags: needinfo?(jteh)
Flags: in-testsuite+

I have no real data, but I imagine the majority of devs (the target audience for Dev Tools) would be using dev edition or at least release. I think we can let this one ride.

Flags: needinfo?(jteh)
You need to log in before you can comment on or make changes to this bug.