Closed Bug 1646319 Opened 3 months ago Closed 3 months ago

Perma [tier 2] TEST-UNEXPECTED-TIMEOUT | /network-error-logging/<test>.https.html |

Categories

(Testing :: web-platform-tests, defect, P5)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: intermittent-bug-filer, Assigned: egao)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=306617055&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/DvRlks7DRMWt2oOEwhP4og/runs/0/artifacts/public/logs/live_backing.log


[task 2020-06-17T10:14:14.802Z] 10:14:14 INFO - PID 14266 | [Parent 14266, Main Thread] WARNING: NS_ENSURE_TRUE(rootFrame) failed: file /builds/worker/checkouts/gecko/dom/base/nsGlobalWindowOuter.cpp, line 4270
[task 2020-06-17T10:14:14.805Z] 10:14:14 INFO - PID 14266 | console.error: SearchCache: "_readCacheFile: Error reading cache file:" (new Error("", "(unknown module)"))
[task 2020-06-17T10:14:14.873Z] 10:14:14 INFO - PID 14266 | [Parent 14266, Main Thread] WARNING: Failed to retarget HTML data delivery to the parser thread.: file /builds/worker/checkouts/gecko/parser/html/nsHtml5StreamParser.cpp, line 1134
[task 2020-06-17T10:14:14.914Z] 10:14:14 INFO - PID 14266 | [Parent 14266, Main Thread] WARNING: '!mLastFocusedWindow', file /builds/worker/checkouts/gecko/widget/gtk/IMContextWrapper.cpp, line 3098
[task 2020-06-17T10:14:16.053Z] 10:14:16 INFO - PID 14266 | [Parent 14266, Main Thread] WARNING: Suboptimal indexes for the SQL statement 0x7f828b88b840 (http://mzl.la/1FuID0j).: file /builds/worker/checkouts/gecko/storage/mozStoragePrivateHelpers.cpp, line 106
[task 2020-06-17T10:14:16.274Z] 10:14:16 INFO -
[task 2020-06-17T10:14:16.274Z] 10:14:16 INFO - TEST-UNEXPECTED-TIMEOUT | /network-error-logging/sends-report-on-redirect.https.html |
[task 2020-06-17T10:14:16.274Z] 10:14:16 INFO - Test that NEL reports are sent for redirects
[task 2020-06-17T10:14:16.274Z] 10:14:16 INFO - - Test timed out
[task 2020-06-17T10:14:16.274Z] 10:14:16 INFO - TEST-INFO | expected FAIL
[task 2020-06-17T10:14:16.275Z] 10:14:16 INFO - TEST-UNEXPECTED-TIMEOUT | /network-error-logging/sends-report-on-redirect.https.html | expected OK
[task 2020-06-17T10:14:16.275Z] 10:14:16 INFO - TEST-INFO took 3178ms

[task 2020-06-17T10:14:13.104Z] 10:14:13 INFO - TEST-START | /network-error-logging/sends-report-on-redirect.https.html

Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | /network-error-logging/sends-report-on-redirect.https.html | → Intermittent TEST-UNEXPECTED-TIMEOUT | /network-error-logging/<test>.https.html |
Summary: Intermittent TEST-UNEXPECTED-TIMEOUT | /network-error-logging/<test>.https.html | → Perma [tier 2] TEST-UNEXPECTED-TIMEOUT | /network-error-logging/<test>.https.html |
Flags: needinfo?(egao)

It looks to be related, I can fix it.

Flags: needinfo?(egao)
Assignee: nobody → egao
Status: NEW → ASSIGNED
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/871c2f8dfb0e
add TIMEOUT expectations for some tests in network-error-logging for macosx1014 web-platform-tests-backlog r=jmaher
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79

:egao , this is also failing on linux1804

Status: RESOLVED → REOPENED
Flags: needinfo?(egao)
Resolution: FIXED → ---
Target Milestone: mozilla79 → ---
Duplicate of this bug: 1647005

(In reply to Narcis Beleuzu [:NarcisB] from comment #6)

:egao , this is also failing on linux1804

Do you have a push for the Linux failures?

The original description only mentioned macosx1014, so I assumed that was the only ones that needed adjustments.

See Also: → 1643177

Issue has been fixed with patch https://phabricator.services.mozilla.com/D80495.

Status: REOPENED → RESOLVED
Closed: 3 months ago3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.