when mozilla saves a file it doesn't save the html you're viewing

RESOLVED DUPLICATE of bug 120809

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 120809
16 years ago
8 years ago

People

(Reporter: Jon Moses, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.0) Gecko/20020530

When you try and save a web page in mozilla, it attempts to re-download the page
from the web site instead of saving the html you are viewing.  This presents a
_major_ problem when you're trying to save an online purchase reciept, as
mozilla will resubmit the order when you try and save the reciept.  This is
extremely undesirable behavior.  The same thing happens for printing and viewing
the source.

Reproducible: Always

Steps to Reproduce:
1. View a web page.
2. Save it.
3. Mozilla gets the copy from the web, rather than the html you're viewing.

Actual Results:  
Mozilla saved the web page from the web, resulting in the commerce site
processing another order request.

Expected Results:  
Saved a copy of the HTML that I was viewing rather than trying to get it from
the web again.
It certainly does not happen for printing -- the printing code has no concept of
"loading" anything.

For view-source, that would be bug 136633 or similar.

For save as that would be bug 120809

*** This bug has been marked as a duplicate of 120809 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Comment 2

8 years ago
Probably more like a dup of bug 288462, since bug 120809 is only for data that are in the cache.
You need to log in before you can comment on or make changes to this bug.