Closed Bug 1646514 Opened 3 years ago Closed 3 years ago

Speedup test generation by reusing the loader instead of new instances

Categories

(Firefox Build System :: Task Configuration, enhancement)

enhancement

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: Callek, Assigned: tomprince)

Details

Attachments

(1 file)

The method get_manifests on the test loader is memoized which should speed it up, however memoize caches on the instance of the class rather than globally. Thus the fact that we recreate the class instance for each task is suboptimal.

Since @memoize on a method is per-instance, use a single instance for all
tests, rather than a new one for each tasks. This gives a ~4x speedup in test
task generation.

Pushed by mozilla@hocat.ca:
https://hg.mozilla.org/integration/autoland/rev/6ef0dbc432ba
Use a single manifest loader for all tests; r=Callek

Dope, thanks for noticing and fixing. The instance used to be stored on the registry, so the regression was a bit subtle.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.