The default bug view has changed. See this FAQ.

file:// Link Can't be opened, have to Copy Link Location, Ctr-Shft-L, and Paste it

RESOLVED DUPLICATE of bug 84128

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 84128
15 years ago
13 years ago

People

(Reporter: eric.aksomitis, Assigned: dougt)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.1b) Gecko/20020721

I have a generated Web Page internally with One line, a Link to open a Logfile
on our LAN in a new window.  I click on the link, try opening it in a new Window
or Tab, but nothing happens.  I can Copy the Link location, open a new window or
tab, Choose Open Location, then paste it in, and it works fine.

Link looks like:
file://s:/...

NOTE:  When I save the HTML page our form generates (as complete web page), then
open IT as a file, I can open the link no problem.  When it is presented as
dummy.cgi, It does not work.  The page properties list it as type Text/html,
with One link in the links tab.

Reproducible: Always

Steps to Reproduce:
1. Generate Web Page from our form
2.  Attemp to click on link
3.
Actual Results:  
Can not open highlited link, except by copying link location, then Ctrl-Shft-L,
then Paste in location (which works no problem).  I then view the Plain-Text
file just fine.

Expected Results:  
Opened the file in a New window by just clicking on it (the URL has a target tag).

The HTML file created is pasted in below.  Note it works when opened as a file,
but when returned from a form of type POST, no such luck.  I can attach the Perl
daemon that created the page if required.

HTML Follows:
<html><head><title>LAUNCHED</title></head><body> Launched script, LogFile Output
Should be in <a href="file:///S:/MR/REXTEAMCNO/BUILDLOGS/LOG1030382650.txt"
target="1030382650"> S:/MR/REXTEAMCNO/BUILDLOGS/LOG1030382650.txt </a></body></html>

Comment 1

15 years ago
Maybe this is because a remote host is not allowed to link to a local
file?

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 122022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

15 years ago
please follow instructions in summary...
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 4

15 years ago
this will get the dupe count correct for the bug w/ the fix request.

*** This bug has been marked as a duplicate of 84128 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE

Updated

15 years ago
Component: Networking: File → User Interface Design

Updated

15 years ago
Component: User Interface Design → Browser-General
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.