Closed Bug 1646633 Opened 2 years ago Closed 2 years ago

Perma devtools/client/storage/test/browser_storage_cache_error.js | A promise chain ... : can't access property "id", this._browser.browsingContext is null - stack: get browsingContextID@resource://devtools/server/actors/descriptors/watcher/watcher.js

Categories

(DevTools :: Framework, defect, P5)

defect

Tracking

(firefox-esr68 unaffected, firefox77 unaffected, firefox78 unaffected, firefox79 fixed)

RESOLVED FIXED
Firefox 79
Tracking Status
firefox-esr68 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: nchevobbe)

References

(Regression)

Details

(Keywords: intermittent-failure, regression)

Attachments

(1 file)

Filed by: csabou [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=306730516&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/ZGOuFPmbRHmmYal3y0pkFg/runs/0/artifacts/public/logs/live_backing.log


[task 2020-06-18T06:24:37.609Z] 06:24:37 INFO - TEST-PASS | devtools/client/storage/test/browser_storage_cache_error.js | The item Cache > http://test2.example.org is present in the tree -
[task 2020-06-18T06:24:37.610Z] 06:24:37 INFO - Buffered messages finished
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - TEST-UNEXPECTED-FAIL | devtools/client/storage/test/browser_storage_cache_error.js | A promise chain failed to handle a rejection: can't access property "id", this._browser.browsingContext is null - stack: get browsingContextID@resource://devtools/server/actors/descriptors/watcher/watcher.js:58:5
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroyTargets@resource://devtools/server/actors/descriptors/watcher/target-helpers/frame-helper.js:58:1
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - unwatchTargets@resource://devtools/server/actors/descriptors/watcher/watcher.js:127:24
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroy@resource://devtools/server/actors/descriptors/watcher/watcher.js:42:12
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroy@resource://devtools/shared/protocol/Pool.js:189:17
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroy@resource://devtools/shared/protocol/Actor.js:76:11
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroy@resource://devtools/server/actors/descriptors/tab.js:220:29
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroy@resource://devtools/shared/protocol/Pool.js:189:17
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroy@resource://devtools/server/actors/root.js:207:36
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - destroy@resource://devtools/shared/protocol/Pool.js:189:17
[task 2020-06-18T06:24:37.615Z] 06:24:37 INFO - onClosed/<@resource://devtools/server/devtools-server-connection.js:485:37
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - onClosed@resource://devtools/server/devtools-server-connection.js:485:22
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - close@resource://devtools/shared/transport/local-transport.js:169:20
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - close@resource://devtools/shared/transport/local-transport.js:165:13
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - cleanup@resource://devtools/client/devtools-client.js:124:27
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - close/promise<@resource://devtools/client/devtools-client.js:140:7
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - close@resource://devtools/client/devtools-client.js:117:21
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - _destroyTarget@resource://devtools/client/fronts/targets/target-mixin.js:567:30
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - destroy@resource://devtools/client/fronts/targets/target-mixin.js:543:12
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - destroy@resource://devtools/client/fronts/targets/browsing-context.js:129:27
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - _destroyToolbox/onceDestroyed</<@resource://devtools/client/framework/toolbox.js:3826:32
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - Rejection date: Thu Jun 18 2020 06:24:35 GMT+0000 (Coordinated Universal Time) - false == true - JS frame :: resource://testing-common/PromiseTestUtils.jsm :: assertNoUncaughtRejections :: line 265
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - Stack trace:
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - resource://testing-common/PromiseTestUtils.jsm:assertNoUncaughtRejections:265
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - chrome://mochikit/content/browser-test.js:Tester_execTest/<:1095
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - Leaving test bound
[task 2020-06-18T06:24:37.616Z] 06:24:37 INFO - GECKO(3687) | JavaScript error: resource://devtools/server/actors/descriptors/watcher/watcher.js, line 58: TypeError: can't access property "id", this._browser.browsingContext is null
[task 2020-06-18T06:24:37.618Z] 06:24:37 INFO - GECKO(3687) | [Parent 3687: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 17 (0x7f70445b6400) [pid = 3687] [serial = 15] [outer = (nil)] [url = about:blank]
[task 2020-06-18T06:24:37.618Z] 06:24:37 INFO - GECKO(3687) | [Parent 3687: Main Thread]: I/DocShellAndDOMWindowLeak --DOMWINDOW == 16 (0x7f70466f6130) [pid = 3687] [serial = 14] [outer = (nil)] [url = about:blank]
[task 2020-06-18T06:24:37.619Z] 06:24:37 INFO - Console message: [JavaScript Error: "TypeError: can't access property "id", this._browser.browsingContext is null" {file: "resource://devtools/server/actors/descriptors/watcher/watcher.js" line: 58}]
[task 2020-06-18T06:24:37.619Z] 06:24:37 INFO - GECKO(3687) | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost

Nicholas, can you have a look over this? Is it related to bug 1646083?

Flags: needinfo?(nchevobbe)

(In reply to Cosmin Sabou [:CosminS] from comment #1)

Nicholas, can you have a look over this? Is it related to bug 1646083?

Probably not because it already changed documentation and no code.
But this should be easy to fix, let me have a look

Flags: needinfo?(nchevobbe)
Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED

Checking this._browser.browsingContext before accessing
its id.

Regressed by: 1639934
See Also: → 1646636
Has Regression Range: --- → yes
Keywords: regression

Set release status flags based on info from the regressing bug 1639934

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/634266b438b1
Fix intermittent on browser_storage_cache_error.js. r=jdescottes,ochameau.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79
You need to log in before you can comment on or make changes to this bug.