quotes and angle brackets are getting converted to html entities

VERIFIED DUPLICATE of bug 16441

Status

()

Core
Editor
P3
normal
VERIFIED DUPLICATE of bug 16441
18 years ago
17 years ago

People

(Reporter: sujay, Assigned: buster)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This bug came in from an internal developer. Not sure if we already
filed this.


M11 Composer did bad things to comments: it appears to get confused by quotes
and angle
brackets and converts them to html entities. For example, on the page I sent you
the header
looked like this in the original:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//EN">

but after editing the page and saving it with composer, it looks like this:

<!DOCTYPE HTML PUBLIC &quot;-//W3C//DTD HTML 3.2 Final//EN&quot;>

It also inserted an extra <style> tag with no closing </style>:

orig:
<style>A {text-decoration:none;}</style>
</head>

post 5.0 edit:
<style>A {text-decoration:none;}
</style>
<style>
</head>

It munged the comments like so:

orig:
<!-- start left column here -->

post 5.0 edit:
&lt;!-- start left column here --&gt;

All of this made the document unrenderable so I'd say this was DOGFOOD material.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

18 years ago
beat you to it, sujay

*** This bug has been marked as a duplicate of 16441 ***
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

18 years ago
verified in 10/18 build.
You need to log in before you can comment on or make changes to this bug.