Closed Bug 1646885 Opened 3 months ago Closed 3 months ago

Intermittent TCw TEST-UNEXPECTED-TIMEOUT | mozilla/tests/baselinecoverage/wpt_baselinecoverage.html | Collecting delayed baseline coverage for web-platform tests. - Test timed out

Categories

(Testing :: General, defect, P5)

defect

Tracking

(firefox79 fixed)

RESOLVED FIXED
mozilla79
Tracking Status
firefox79 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: egao)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

Filed by: ccoroiu [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer.html#?job_id=306835601&repo=mozilla-central
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/bSgMKcwKS7WJR4Npj0ZWZg/runs/0/artifacts/public/logs/live_backing.log


task 2020-06-18T22:56:43.117Z] 22:56:43 INFO - TEST-START | /_mozilla/baselinecoverage/wpt_baselinecoverage.html
[task 2020-06-18T22:56:44.232Z] 22:56:44 INFO - PID 3959 | [CodeCoverage] Setting handlers for process 4192.
[task 2020-06-18T22:56:58.919Z] 22:56:58 INFO -
[task 2020-06-18T22:56:58.919Z] 22:56:58 INFO - TEST-PASS | /_mozilla/baselinecoverage/wpt_baselinecoverage.html | Collecting basic baseline coverage for web-platform tests.
[task 2020-06-18T22:56:58.919Z] 22:56:58 INFO - TEST-UNEXPECTED-TIMEOUT | /_mozilla/baselinecoverage/wpt_baselinecoverage.html | Collecting delayed baseline coverage for web-platform tests. - Test timed out
[task 2020-06-18T22:56:58.919Z] 22:56:58 INFO - TEST-UNEXPECTED-TIMEOUT | /_mozilla/baselinecoverage/wpt_baselinecoverage.html | expected OK
[task 2020-06-18T22:56:58.919Z] 22:56:58 INFO - TEST-INFO took 15803ms
[task 2020-06-18T22:56:58.919Z] 22:56:58 INFO - No more tests
[task 2020-06-18T22:56:58.941Z] 22:56:58 INFO - PID 3959 | 1592521018935 Marionette INFO Stopped listening on port 55666
[task 2020-06-18T22:56:59.143Z] 22:56:59 INFO - PID 3959 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T22:56:59.143Z] 22:56:59 INFO - PID 3959 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T22:56:59.144Z] 22:56:59 INFO - PID 3959 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T22:56:59.284Z] 22:56:59 INFO - PID 3959 | ###!!! [Parent][RunMessage] Error: Channel closing: too late to send/recv, messages will be lost
[task 2020-06-18T22:57:02.787Z] 22:57:02 INFO - Browser exited with return code 0
[task 2020-06-18T22:57:02.787Z] 22:57:02 INFO - PROCESS LEAKS None
[task 2020-06-18T22:57:02.788Z] 22:57:02 INFO - Closing logging queue
[task 2020-06-18T22:57:02.788Z] 22:57:02 INFO - queue closed
[task 2020-06-18T22:57:02.788Z] 22:57:02 INFO - PROCESS LEAKS None
[task 2020-06-18T22:57:02.843Z] 22:57:02 INFO - Got 2 unexpected results
[task 2020-06-18T22:57:02.844Z] 22:57:02 INFO - SUITE-END | took 29s
[task 2020-06-18T22:57:02.871Z] 22:57:02 INFO - Removed font: Ahem.ttf
[task 2020-06-18T22:57:02.878Z] 22:57:02 INFO - Closing logging queue
[task 2020-06-18T22:57:02.880Z] 22:57:02 INFO - queue closed
[task 2020-06-18T22:57:03.050Z] 22:57:03 ERROR - Return code: 1

This task does not run very often. It looks like it has been perma-fail since June 17. The previous run failed with bug 1645974.

See Also: → 1645974

The previous successful run was:
https://firefoxci.taskcluster-artifacts.net/LhS99iRVRpSC8pCbpEToPg/0/public/logs/live_backing.log

[task 2020-06-15T17:51:15.034Z] 17:51:15     INFO - TEST-START | /_mozilla/baselinecoverage/wpt_baselinecoverage.html
[task 2020-06-15T17:51:16.117Z] 17:51:16     INFO - PID 15228 | [CodeCoverage] Setting handlers for process 15476.
[task 2020-06-15T17:51:45.808Z] 17:51:45     INFO - ..
[task 2020-06-15T17:51:45.808Z] 17:51:45     INFO - TEST-OK | /_mozilla/baselinecoverage/wpt_baselinecoverage.html | took 30775ms

Notice that it took 30 seconds to pass; now it is timing out after 15 seconds.

:egao -- might this be related to some of your changes to wpt timeouts?

Flags: needinfo?(egao)

(In reply to Geoff Brown [:gbrown] from comment #3)

The previous successful run was:
https://firefoxci.taskcluster-artifacts.net/LhS99iRVRpSC8pCbpEToPg/0/public/logs/live_backing.log

[task 2020-06-15T17:51:15.034Z] 17:51:15     INFO - TEST-START | /_mozilla/baselinecoverage/wpt_baselinecoverage.html
[task 2020-06-15T17:51:16.117Z] 17:51:16     INFO - PID 15228 | [CodeCoverage] Setting handlers for process 15476.
[task 2020-06-15T17:51:45.808Z] 17:51:45     INFO - ..
[task 2020-06-15T17:51:45.808Z] 17:51:45     INFO - TEST-OK | /_mozilla/baselinecoverage/wpt_baselinecoverage.html | took 30775ms

Notice that it took 30 seconds to pass; now it is timing out after 15 seconds.

:egao -- might this be related to some of your changes to wpt timeouts?

It might be. I'll take a look.

Flags: needinfo?(egao)
Assignee: nobody → egao
Status: NEW → ASSIGNED
Pushed by egao@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7414212ee67a
add backlog flag to be passed to mozharness and set timeout multiplier appropriately r=jmaher
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
You need to log in before you can comment on or make changes to this bug.