Liveconnect not working in Mac 10.2

VERIFIED DUPLICATE of bug 164712

Status

--
major
VERIFIED DUPLICATE of bug 164712
16 years ago
8 years ago

People

(Reporter: french, Assigned: beard)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020826
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1b) Gecko/20020826

I put the above url in as an example. However none of the pages that I tested
with liveconnect worked. I turned on the java Console and when the java tries to
make the call back to the javascript the following exception is thrown

Exception occurred during event dispatching:
netscape.javascript.JSException
	at netscape.javascript.JSObject.getWindow(JSObject.java:141)
	at Pendulum.setWinVal(Pendulum.java:77)
	at Pendulum.mouseUp(Pendulum.java:72)
	at java.awt.Component.handleEvent(Component.java:3889)
	at java.awt.Component.postEvent(Component.java:2784)
	at java.awt.Component.dispatchEventImpl(Component.java:2601)
	at java.awt.Container.dispatchEventImpl(Container.java:1208)
	at java.awt.Component.dispatchEvent(Component.java:2493)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:334)
	at
java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:126)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:88)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:80)

On the other hand when you try to set the length of the Pendulum from the
javascript side the browser just sit there without any feed back. 

Reproducible: Always

Steps to Reproduce:
1.Go to the Untilities in the Applications folder. Then choose java and the java
plugin settings and choose to have the java console on
2.go to the above url. click to start the applet.
3.Then put in a length for the Pendulum

Actual Results:  
When the applet is first click on the applet it throws the java exception.
When a length is put in nothing happens

Expected Results:  
When the applet is clicked on the length should show in the test box below the
applet. When a legth is entered it should change the actul length of the
pendulum in the applet

Comment 1

16 years ago
James, is this a new problem specific to Mac 10.2?
Was all this working in the previous release of Mac OS X? 
Summary: Liveconnect not working in Mac 10.2 → Liveconnect not working in Mac 10.2
(Reporter)

Comment 2

16 years ago
This use to work in Mozilla with the mrjplugin. However now that they have gone
to the java Applet.plugin it is no longer working.

Comment 3

16 years ago
OK, I think this is what Patrick was explaining to me the other day.
Reassigning to OJI component and to Patrick -
Assignee: rogerl → beard
Status: UNCONFIRMED → NEW
Component: Live Connect → OJI
Ever confirmed: true
QA Contact: pschwartau → pmac
bug 164712 appears to have a patch for this.

*** This bug has been marked as a duplicate of 164712 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified Duplicate -
Status: RESOLVED → VERIFIED

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.