"untitled" appears as tab or window's title while page is loading

VERIFIED FIXED

Status

VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: bugzilla, Assigned: sfraser_bugs)

Tracking

Details

(Reporter)

Description

16 years ago
if you open a link in a new tab and quickly go to that new tab before the page
finishes loading, the tab's title will say "untitled".

steps to repro/observe:

1. on a page with links, such a bug query listing, start opening some links in
new tabs. it doesn't matter if you use cmd-click link (if that pref is set) or
"open link in new tab" from the context menu. nor does it matter if you load the
new tabs in the foreground or background.

2. since i usually have background loading on, i noticed that the new tab will
*initially* say "Loading..." i quickly bring this new tab to the foreground, and
its title changes to "untitled". in addition, its site icon will be the plain
file icon (the urlbar will be blank and have only that icon), and the status bar
will say "Document: Done".

3. once the page is nearly finished loading, however, the status bar will change
to "Transferring from [etc]..." when done, the urlbar and tab title update with
the proper information.
i thought there was a dupe of this somewere, but i can't find it now.
(Reporter)

Comment 2

16 years ago
i thought so, too...but couldn't find it after several queries. if one is found,
feel free to dup this one!
(Reporter)

Comment 3

16 years ago
okay, this isn't really limited to tabs. it's just more obvious with tabs due to
the perf bug 159672.
Component: Tabbed Browsing → General
Summary: "untitled" appears as tab's title while page is loading → "untitled" appears as tab or window's title while page is loading
(Reporter)

Updated

16 years ago
Depends on: 159672
(Assignee)

Comment 4

16 years ago
I have a fix for this.
Status: NEW → ASSIGNED
(Assignee)

Comment 5

16 years ago
Fixed: when switching tabs, don't nuke the tab title if it's still loading, and
maintain separate window and tab titles for each browser.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

16 years ago
tested with 2002.12.03.04 on 10.2.2. looks good when loading content in tabs,
but "untitled" still lingers in the titlebar of new windows.

should i just spin off another bug for the new window case, or reopen this one?
(Reporter)

Comment 7

16 years ago
okay, am gonna vrfy this one. spun off bug 183546 for the window titlebar case.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.