Closed Bug 1647066 Opened 1 year ago Closed 1 year ago

Permafailing test_<anything>_interfaces.html | false: If this is failing: DANGER, are you sure you want to expose the new interface AggregateError to all webpages as a property on the worker? when Gecko 79 merges to Beta on 2020-06-29

Categories

(Core :: DOM: Workers, defect)

defect

Tracking

()

VERIFIED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 + verified

People

(Reporter: nataliaCs, Assigned: jorendorff)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Central as Beta: https://treeherder.mozilla.org/#/jobs?repo=try&group_state=expanded&revision=a9acfe0eb85d3fedc68cd8f1c44eb62efa37ba66&searchStr=mochitest-plain

Failure log example: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=306944626&repo=try&lineNumber=3244

[task 2020-06-20T11:35:40.976Z] 11:35:40 INFO - TEST-PASS | dom/workers/test/test_worker_interfaces.html | true: If this is failing: DANGER, are you sure you want to expose the new interface RegExp to all webpages as a property on the worker? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-06-20T11:35:40.977Z] 11:35:40 INFO - TEST-PASS | dom/workers/test/test_worker_interfaces.html | true: If this is failing: DANGER, are you sure you want to expose the new interface Error to all webpages as a property on the worker? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-06-20T11:35:40.977Z] 11:35:40 INFO - TEST-PASS | dom/workers/test/test_worker_interfaces.html | true: If this is failing: DANGER, are you sure you want to expose the new interface InternalError to all webpages as a property on the worker? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-06-20T11:35:40.978Z] 11:35:40 INFO - Buffered messages finished
[task 2020-06-20T11:35:40.978Z] 11:35:40 INFO - TEST-UNEXPECTED-FAIL | dom/workers/test/test_worker_interfaces.html | false: If this is failing: DANGER, are you sure you want to expose the new interface AggregateError to all webpages as a property on the worker? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)
[task 2020-06-20T11:35:40.979Z] 11:35:40 INFO - SimpleTest.ok@SimpleTest/SimpleTest.js:299:16
[task 2020-06-20T11:35:40.979Z] 11:35:40 INFO - workerTestExec/worker.onmessage@dom/workers/test/worker_driver.js:35:9
[task 2020-06-20T11:35:40.979Z] 11:35:40 INFO - TEST-PASS | dom/workers/test/test_worker_interfaces.html | true: If this is failing: DANGER, are you sure you want to expose the new interface EvalError to all webpages as a property on the worker? Do not make a change to this file without a review from a DOM peer for that specific change!!! (or a JS peer for changes to ecmaGlobals)

Could this be caused by the patch in Bug 1646009 ?
Jason could you help us with a quick check?
Thank you.

Flags: needinfo?(jorendorff)

Yes, that's the cause. This is easy to fix, though.

Assignee: nobody → jorendorff
Status: NEW → ASSIGNED
Pushed by jorendorff@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c55cdcde849
Fix interfaces tests for shipping AggregateError to beta. r=jwalden.
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla79
Flags: needinfo?(jorendorff)
You need to log in before you can comment on or make changes to this bug.