Closed Bug 1647170 Opened 2 months ago Closed 2 months ago

ReferenceError: rearrangeAttendees is not defined in calendar event window

Categories

(Calendar :: Dialogs, defect)

defect

Tracking

(thunderbird78 fixed)

RESOLVED FIXED
Thunderbird 79.0
Tracking Status
thunderbird78 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

Attachments

(1 file)

This is caused because of a resize event as the window opens. The function rearrangeAttendees doesn't exist at that point.

Oh and also rearrangeAttendees is totally broken in this dialog because we changed it for the summary dialog. :-/

Attachment #9158078 - Flags: review?(paul)
Attachment #9158078 - Flags: approval-calendar-beta?(paul)
Comment on attachment 9158078 [details] [diff] [review]
1647170-rearrange-attendees-1.diff

Review of attachment 9158078 [details] [diff] [review]:
-----------------------------------------------------------------

Oof... thanks for catching and fixing this.  Changes look good and I checked that the error was gone from the console and that attendees were rearranged correctly.
Attachment #9158078 - Flags: review?(paul)
Attachment #9158078 - Flags: review+
Attachment #9158078 - Flags: approval-calendar-beta?(paul)
Attachment #9158078 - Flags: approval-calendar-beta+
Regressed by: 1637133

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/d051d1812f3c
Fix "ReferenceError: rearrangeAttendees is not defined" in calendar event window. r=pmorris

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 79
Target Milestone: 79 → 78
Target Milestone: Thunderbird 78.0 → Thunderbird 79.0
You need to log in before you can comment on or make changes to this bug.