Closed Bug 1647336 Opened 3 months ago Closed 3 months ago

Incorrect icon for HTTPS-Only Mode error page

Categories

(Firefox :: Site Identity, defect, P3)

defect

Tracking

()

VERIFIED FIXED
Firefox 80
Tracking Status
firefox80 --- verified

People

(Reporter: arthur, Assigned: julianwels)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [domsecurity-backlog1])

Attachments

(2 files)

Steps to reproduce:

  1. Enter "ox.ac.uk" in the URL bar
  2. After the error page is displayed, click "Accept the Risk and Continue to Site"
  3. The content page is loaded.

Results:

Even though we are viewing content (and not the error page), a "document" icon is still shown (see attached image)

Expected Results:

A "disabled lock" icon should be shown when we are on the content page.

Severity: -- → S4
Priority: -- → P3
Whiteboard: [domsecurity-backlog1]

Does that issue still come up in the latest Nightly? It came up last week on my debug build and Nightly but I can't reproduce it now.

Flags: needinfo?(arthur)

Yes -- I just confirmed it on 20200623034439 on MacOS.

Flags: needinfo?(arthur)

I also noticed that if you tab away and tab back, then the icon changes to the correct one.

Assignee: nobody → julianwels
Status: NEW → ASSIGNED
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5ceef37ac0af
Fixed incorrect icon and site-identity information on HTTPS-Only Error Page. r=nhnt11
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Component: DOM: Security → Site Identity
Product: Core → Firefox
Regressed by: 1651062
Target Milestone: mozilla80 → ---
Regressed by: 1570678
No longer regressed by: 1651062
Target Milestone: --- → Firefox 80
Flags: qe-verify+
See Also: → 1656027

Renamed bug because it accidentally fixed another issue.
The original issue is now being tracked with bug 1656027.

Summary: Incorrect icon for whitelisted site in HTTPS Only Mode → Incorrect icon for HTTPS-Only Mode error page

Was unable to confirm the issue either (2020-06-22-09-33-09 - macOS 10.15).
However, verified with 80.0b6 on Windows 10, macOS 10.15.5, Ubuntu 16 and everything appears in order.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.