Closed Bug 1647372 Opened 3 months ago Closed 2 months ago

Complete the implementation of GetOverflowingChildrenOfElement

Categories

(DevTools :: Inspector, defect, P3)

defect

Tracking

(firefox80 fixed)

RESOLVED FIXED
Firefox 80
Tracking Status
firefox80 --- fixed

People

(Reporter: bradwerth, Assigned: manas.khurana20, Mentored)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Bug 1639893 introduced the GetOverflowingChildrenOfElement InspectorUtils method, and provided a stub implementation that always reports the first child of an element as causing overflow -- whether it does or not. This bug will be used to correct and complete the implementation, and add appropriate tests.

Mentor: bwerth
Severity: -- → S4
Priority: -- → P3

This is the start of a test. It is untested and may have typos. It needs many more cases added.

Attachment #9159331 - Attachment description: Bug 1647372 Part 1 - Add IsFrameBiggerThanSize and FrameHasSpecifiedSize. r=bradwerth → Bug 1647372 Part 1 - Add IsFrameOutsideOfAncestor and FrameHasSpecifiedSize. r=bradwerth
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f2154316c34d
Part 1 - Add IsFrameOutsideOfAncestor and FrameHasSpecifiedSize. r=bradwerth,emilio
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b9c312c44c6
Part 2 - Add tests for GetOverflowingChildrenOfElement. r=bradwerth
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
Duplicate of this bug: 1638000
You need to log in before you can comment on or make changes to this bug.