Closed Bug 1647375 Opened 2 years ago Closed 2 years ago

Profile Manager can Wipe Profiles Without Warning and Without Moving to Trash Folder

Categories

(Toolkit :: Startup and Profile System, defect)

77 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 302087

People

(Reporter: erwinm, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.3

Steps to reproduce:

I lost my Firefox installation. (Currently posting from Waterfox.)

In response to a needinfo request on bug 1644041 I tried to create and test a new profile, but lost my current profile, with all my accessibility and safety fixes.

I opened the pfile manager, tried to create a new profile, selected my Library/Application Support/Firefox/Profiles, realized this was the wrong location and deleted the misplaced profile.

Actual results:

... Which deleted all my profiles, without moving them to the Trash. Because the MacOS Time Machine fails to back up libraries, the usual backupers were gone. I was still in Firefox, trying to figure out how to emergency backup, but all the instructions assumed an intact profiles folder.

Expected results:

Deleing profiles should move the files to the trash.

Summary: Profile Manager can Wipe Profiles Without Warning → Profile Manager can Wipe Profiles Without Warning and Without Recoverability

I mean MacOS Time Machine does not reliably back up library folders, so key files may be missing. I lost safety settings, to block flashing and animation, the last time I had to restore from Time Machine.

P.S. I was able to restore from Time Machine, without losing most settings, this time. Had the "Your Firefox profile cannot be loaded" warning, but no further trouble so far.

Summary: Profile Manager can Wipe Profiles Without Warning and Without Recoverability → Profile Manager can Wipe Profiles Without Warning and Without Moving to Trash Folder

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 302087
You need to log in before you can comment on or make changes to this bug.