Closed Bug 1647787 Opened 7 months ago Closed 7 months ago

Remove whitelist/blacklist from frontend performance tests

Categories

(Firefox :: General, defect)

defect

Tracking

()

RESOLVED FIXED
Firefox 79
Tracking Status
firefox79 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Let's get rid of this terminology.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9c35e1ec27d8
remove use of whitelist/blacklist from front-end performance tests, r=mconley
Regressions: 1648201
Regressions: 1648207
Regressions: 1648206

This patch just changed comments in the urlbar test, nothing else, so it can't have caused those regressions. I also expect it won't have caused the layout.dpi regression, and instead the cause is whatever caused the urlbar tests to start failing. Please can you doublecheck the regression range?

Flags: needinfo?(ncsoregi)
No longer regressions: 1648201, 1648206
No longer regressions: 1648207

(the prefs "regression" was just a change in the message, but the intermittent was already known. I've updated the summary of the older bug.)

:Gijs thank you for checking this and removing the regressions.
I will further investigate.

Flags: needinfo?(ncsoregi)
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 79

(In reply to Natalia Csoregi [:nataliaCs] from comment #5)

:Gijs thank you for checking this and removing the regressions.
I will further investigate.

I'll add that I only just realized that the 2 urlbar-test-related bugs are also TV bugs; because it's a TV failure, it's unclear when that would have been introduced (as it presents when repeatedly running the same test), although it's possible there are similar/identical non-TV intermittents already on file, that are just showing up as TV issues now that the test is being changed.

Still, changing a bit of English text in a comment in the test of course shouldn't be influencing how the test works. :-)

You need to log in before you can comment on or make changes to this bug.