Colour sticks when setting *.style.background via JavaScript [inline]

VERIFIED WORKSFORME

Status

()

Core
CSS Parsing and Computation
VERIFIED WORKSFORME
16 years ago
12 years ago

People

(Reporter: Marcus Campbell, Assigned: dbaron)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
2002082508, WinNT

I wrote a JavaScript function that toggles the background colour of table cells
on mouseover / mouseout of images and links by setting a colour value to
*.style.background, however, it doesn't work as expected.

On first mouseover the colour changes, sticks and doesn't reset on mouseout.
Only after you mouseover again, does it begin to work properly.

(Plus, when I was using an image with transparency, the background colour wasn't
rendering to the full width of the cell on first mouseover.)

It works fine when you set *.style.backgroundColor instead.
(Reporter)

Comment 1

16 years ago
Created attachment 96834 [details]
Testcase
To tables...   I see this on Linux too.
Assignee: jst → karnaze
Component: DOM Style → HTMLTables
OS: Windows NT → All
QA Contact: ian → amar
Hardware: PC → All
(Assignee)

Comment 3

16 years ago
Seems more like a style system bug to me.
Assignee: karnaze → dbaron
Component: HTMLTables → Style System
QA Contact: amar → ian
Summary: Colour sticks when setting *.style.background via JavaScript → Colour sticks when setting *.style.background via JavaScript [inline]
This seems to be fixed by the patch in bug 171830
Depends on: 171830
Please retest with tomorrow's build (I cannot reproduce this in a current
nightly without the patch for bug 171830 even, so....)

Comment 6

15 years ago
wfm with a current nightly (Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b)
Gecko/20030414) as well as with Moz1.4a on win98 using the testcase.
marking so.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.