Closed Bug 1648623 Opened 3 months ago Closed 3 months ago

Perma SM asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type when Gecko 79 merges to Beta on 2020-06-29

Categories

(Core :: Javascript: WebAssembly, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla79
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 + verified

People

(Reporter: CosminS, Assigned: rhunt)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Central as beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Csuccess%2Cretry%2Crunning%2Cpending%2Crunnable&revision=d7d711ac6ec0edbc7e4e916c742273c2da829304&searchStr=sm&selectedTaskRun=eRA-iOxaR5m-05PyeY7SYw.0

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=307528327&repo=try

[task 2020-06-25T15:33:51.055Z] TEST-PASS | js/src/jit-test/tests/wasm/gc/anyref.js | Success (code 0, args "--disable-wasm-huge-memory") [0.2 s]
[task 2020-06-25T15:33:51.084Z] /builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type
[task 2020-06-25T15:33:51.086Z] Stack:
[task 2020-06-25T15:33:51.086Z]   assertErrorMessage@/builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27
[task 2020-06-25T15:33:51.087Z]   checkInvalid@/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:9:23
[task 2020-06-25T15:33:51.087Z]   @/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:21:13
[task 2020-06-25T15:33:51.087Z] Exit code: 3
[task 2020-06-25T15:33:51.087Z] FAIL - wasm/gc/binary.js
[task 2020-06-25T15:33:51.088Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/wasm/gc/binary.js | /builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type (code 3, args "") [0.2 s]
[task 2020-06-25T15:33:51.088Z] INFO exit-status     : 3
[task 2020-06-25T15:33:51.088Z] INFO timed-out       : False
[task 2020-06-25T15:33:51.088Z] INFO stderr         2> /builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type
[task 2020-06-25T15:33:51.088Z] INFO stderr         2> Stack:
[task 2020-06-25T15:33:51.088Z] INFO stderr         2> assertErrorMessage@/builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27
[task 2020-06-25T15:33:51.088Z] INFO stderr         2> checkInvalid@/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:9:23
[task 2020-06-25T15:33:51.088Z] INFO stderr         2> @/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:21:13
[task 2020-06-25T15:33:51.141Z] TEST-PASS | js/src/jit-test/tests/wasm/gc/anyref-val-tracing.js | Success (code 0, args "--ion-eager --ion-offthread-compile=off --ion-check-range-analysis --ion-extra-checks --no-sse3 --no-threads") [0.7 s]
[task 2020-06-25T15:33:51.193Z] /builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type
[task 2020-06-25T15:33:51.193Z] Stack:
[task 2020-06-25T15:33:51.194Z]   assertErrorMessage@/builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27
[task 2020-06-25T15:33:51.194Z]   checkInvalid@/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:9:23
[task 2020-06-25T15:33:51.194Z]   @/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:21:13
[task 2020-06-25T15:33:51.194Z] Exit code: 3
[task 2020-06-25T15:33:51.194Z] FAIL - wasm/gc/binary.js
[task 2020-06-25T15:33:51.194Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/wasm/gc/binary.js | /builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type (code 3, args "--blinterp-eager") [0.1 s]
[task 2020-06-25T15:33:51.194Z] INFO exit-status     : 3
[task 2020-06-25T15:33:51.194Z] INFO timed-out       : False
[task 2020-06-25T15:33:51.194Z] INFO stderr         2> /builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type
[task 2020-06-25T15:33:51.194Z] INFO stderr         2> Stack:
[task 2020-06-25T15:33:51.194Z] INFO stderr         2> assertErrorMessage@/builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27
[task 2020-06-25T15:33:51.194Z] INFO stderr         2> checkInvalid@/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:9:23
[task 2020-06-25T15:33:51.194Z] INFO stderr         2> @/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:21:13
[task 2020-06-25T15:33:51.204Z] TEST-PASS | js/src/jit-test/tests/wasm/gc/binary.js | Success (code 59, args "--wasm-gc") [0.1 s]
[task 2020-06-25T15:33:51.208Z] /builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27 Error: Assertion failed: expected /ref/, got at offset 25: bad type
[task 2020-06-25T15:33:51.208Z] Stack:
[task 2020-06-25T15:33:51.208Z]   assertErrorMessage@/builds/worker/checkouts/gecko/js/src/jit-test/lib/asserts.js:65:27
[task 2020-06-25T15:33:51.208Z]   checkInvalid@/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:9:23
[task 2020-06-25T15:33:51.208Z]   @/builds/worker/checkouts/gecko/js/src/jit-test/tests/wasm/gc/binary.js:21:13
[task 2020-06-25T15:33:51.208Z] Exit code: 3
[task 2020-06-25T15:33:51.209Z] FAIL - wasm/gc/binary.js

Looks to be from Bug 1637884. Ryan, could you please have a look?

Flags: needinfo?(rhunt)

Presumably just a missing guard since reftypes are now on non-nightly but GC still is not.

Assignee: nobody → rhunt
Severity: -- → S3
Status: NEW → ASSIGNED
Priority: -- → P1

This test uses GC features, not reftypes features.

Pushed by rvandermeulen@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a44f97359a10
Properly gate gc/binary.js test on GC proposal. r=RyanVM
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/3285aa54f529
Backed out changeset a44f97359a10 because the wrong phab revision landed.
https://hg.mozilla.org/integration/autoland/rev/1f9316f12277
Properly gate gc/binary.js test on GC proposal. r=RyanVM on a CLOSED TREE
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/64c1c058a255
Follow-up to fix SM bustages. r=RyanVM CLOSED TREE
Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/79d8641e87c3
Removing extra characters. r=RyanVM CLOSED TREE
Flags: needinfo?(rhunt)
You need to log in before you can comment on or make changes to this bug.