If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Status

()

Core
Plug-ins
--
minor
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: tracy, Assigned: Brian Nesse (gone))

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
seen on build 2002-08-27-05

-goto java.sun.com/applets
-attempt to load LED (applet example)
the applet doesn't load.

no java applets will load from any page
(Reporter)

Updated

15 years ago
Keywords: smoketest
Summary: smoketest → Java applets won't load

Comment 1

15 years ago
I do get the applets to load in 10.2 with the same version. Looks like it's
using the Apple Java plugin. Are you running under 10.1 ?
(Reporter)

Comment 2

15 years ago
I'm running 10.1.5
Patty Mac could also reproduce this.  I don't know what she is running.

Comment 3

15 years ago
are there multiple java plugins on the affected systems?

Comment 4

15 years ago
Ok, pulled the 2002-08-27-05 build and can reproduce the problem as reported
under  0S X 10.1.4. If I type about: plugins, I do see MRJ Java Plugin listed
though.
(Assignee)

Comment 5

15 years ago
Did this work with the 8/26 build?

Comment 6

15 years ago
Going to pull that build and try it.
(Reporter)

Comment 7

15 years ago
I am checking when this started: it was there on 8/26  going back further to 
find out when this regressed.
(Reporter)

Comment 8

15 years ago
java applets worked through the 08-23-05 build
from the 08-24-05 build until present java applets do not work.

Comment 9

15 years ago
FWIW, I found out why the MRJ plugin is showing up in the about:plugins list.
The OS X (10.1.4) machine has the plugin located at ~Library/Internet Plugins.
My freshly installed OS X 10.2 doesn't have the plugin residing there.
(Assignee)

Comment 10

15 years ago
That timeframe would seem to implicate beards 10.2 compatibility fix which I
landed on Friday. This seems odd because it didn't break 10.1.5 compatibility on
the CFM plugin.

Comment 11

15 years ago
Tracy, I have Mac OS 10.1.5, when I type: about:plugins, I do not see MRJ Java 
Plugin listed though. Go to ~Library/Internet Plugins, I don't see plugin there.
That's why I try to load applets, it doesn't load.
Brian, pulled the 2002-08-27-05 build, is this build going to bundle the MRJ 
plugin or should I have to do special way like copy the plugin itself into
 ~Library/Internet Plugins?

Comment 12

15 years ago
So currently, there is a work-around on my Mac os 10.1.5 if using the build 
2002-08-27-05, the url to download the plugin below here:
http://homepage.mac.com/pcbeard/MRJPlugin/MRJPlugin_for_Chimera.dmg.gz
and then drag the "MRJPlugin.plugin" to the ~Library/Internet Plugins folder.
It loads the applets though. The date of "MRJPlugin.plugin" was 6/4/02.

Brian, Is the url above, the latest version of plugin?


(Assignee)

Comment 13

15 years ago
So, the problem is that we are not scanning plug-ins in the Application
directory. The workaround is to remove the MRJPlugin.plugin bundle from the
Navigator bundle and stick it in /Library/Internet Plug-ins.
(Assignee)

Comment 14

15 years ago
The call to dirService->Get(NS_OS_PLUGINS_DIR_LIST) in
nsPluginHostImpl::FindPlugins() is returning an error. Conrad, is this
(NS_OS_PLUGINS_DIR_LIST) something we need to add specific support for in
Chimera? I think it came in during the 1.0 -> 1.0.1 branch switch.

http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/xpcom/io/nsAppFileLocationProvider.cpp&rev=CHIMERA_M1_0_1_BRANCH&root=/cvsroot#89
We are attempting to scan the local plugins dir but, because of this, we looking
for "Plug-Ins", not "plugins"

Unless we really want to have XP_MAC style names for these dirs under XP_MACOSX,
the easy thing to do is to change this #ifdef.

> The call to dirService->Get(NS_OS_PLUGINS_DIR_LIST) in
nsPluginHostImpl::FindPlugins() is returning an error.

The error is ignored by the plugin loader. This key was only ever supported for
Mac and now, isn't even supported there. It's definition should be removed.

Comment 16

15 years ago
0.5 blocker
Target Milestone: --- → Chimera0.5
(Assignee)

Comment 17

15 years ago
Created attachment 97047 [details] [diff] [review]
Patch for Chimera tree

Patch for Chimera as per discussion with Conrad.
Why don't we want to use the mac names? This is still a mac app, you know.
(Assignee)

Comment 19

15 years ago
A number of reasons I believe. For one simplification of sources and build
system. Another is that now that this stuff is hidden inside a package, we
didn't think it was that important. Conrad may have others...

Comment 20

15 years ago
Won't plugin installers be looking for "Plug-ins" ? Or do we assume that they'll
either a) not know about chimera anyway, or b) just install in user- or
system-wide locations?
(Assignee)

Comment 21

15 years ago
As far as I know all plugin vendors now are using the system defined plugin
directories as it greatly simplifies their installation process.
(Assignee)

Comment 22

15 years ago
Created attachment 97054 [details] [diff] [review]
Moz trunk patch

Cleanup patch for trunk. Simply removes dead code bits. No OS X issues here.
Attachment #97047 - Flags: review+
Comment on attachment 97047 [details] [diff] [review]
Patch for Chimera tree

r=ccarlen

I discussed it with Brian and agree with his points about which dir names are
used.
Comment on attachment 97054 [details] [diff] [review]
Moz trunk patch

r=ccarlen
Attachment #97054 - Flags: review+
(Assignee)

Comment 25

15 years ago
The #ifdef in nsAppFileLocationProvider.cpp changed during the code sync from 1.0 
to 1.0.1. Until the 1.0 -> 1.0.1 sync, we were using the non MacOS support (i.e. 
lower case, no hyphens or spaces versions of the directory names) case. Now we 
are not, but the build system hasn't changed to reflect this. Attachment showing 
the changes coming. cc'ing bryner, who probably made the changes.
(Assignee)

Comment 26

15 years ago
Created attachment 97062 [details] [diff] [review]
Portion of the patch which caused this regression
(Assignee)

Updated

15 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 27

15 years ago
Discussed the current state of this with bryner and sfraser. Landing as is.
Chimera patch checked in. Leaving open for trunk patch.

Can I get an sr for the trunk patch?

Updated

15 years ago
Blocks: 147975
(Reporter)

Comment 28

15 years ago
Was the fix checked in? 
This is working now as seen on chimera build for 2002-08-29-05
it's only been checked in for chimera, but not the main trunk.
(Assignee)

Comment 30

15 years ago
Right, but the trunk patch doesn't actually "fix" a bug, it's really just dead
code cleanup.

Comment 31

15 years ago
If this doesn't fix a bug on the Trunk, then why is it marked as a Smoketest
Blocker for the Trunk? That is, when I click on the query for Smoketest
Blockers, I see this bug.
(Assignee)

Comment 32

15 years ago
It was a smoketest blocker for the Chimera branch, not the trunk. Removing keyword.
Keywords: smoketest

Comment 33

15 years ago
Yep, applets are working for me too using the 2002-08-29-05 build under OS X
10.2. Removed apple's java plugins from my Internet plugins folder just so I
make sure we are using our packaged MRJ one.
(Assignee)

Comment 34

15 years ago
Updating fields to reflect reality...getting this off my Chimera bug list as it
is fixed there.
No longer blocks: 147975
Severity: blocker → minor
Product: Chimera → Browser
Summary: Java applets won't load → Remove dead plugin code
Target Milestone: Chimera0.5 → ---
Version: unspecified → other

Comment 35

15 years ago
Comment on attachment 97054 [details] [diff] [review]
Moz trunk patch

sr=beard
Attachment #97054 - Flags: review+ → superreview+
(Assignee)

Comment 36

15 years ago
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.