Closed Bug 1649285 Opened 1 year ago Closed 2 months ago

non-WR/Mali-G76: Text becomes blurred when moving a page

Categories

(Core :: Graphics: Text, defect, P3)

Unspecified
Android
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: haswellready, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Android 10; Mobile; rv:78.0) Gecko/78.0 Firefox/78.0

Steps to reproduce:

Text becomes blurred when swyping right any page with code on github.
See example here: https://youtu.be/nS3VdtTaHlI

Actual results:

Text on the left becomes blurred

Expected results:

Text Should remains sharp

Component: General → Graphics: Text
OS: Unspecified → Android
Product: Firefox for Android → Core
Version: unspecified → Trunk
Severity: -- → S3
Flags: needinfo?(ktaeleman)
Priority: -- → P3

Can't reproduce this on Fenix Nightly 200703 08:40 with or without Webrender.

@haswellready: Can you still reproduce this on latest nightly? If so, could you attach your about:support information?

Flags: needinfo?(ktaeleman) → needinfo?(haswellready)

Still reproducible on my side on Firefox Nightly 200705 06:01 using this link (but intermittent as before):
https://github.com/mozilla/DeepSpeech/blob/d2d46c3aee2f5ea2357628b6614d860bdf748844/training/deepspeech_training/train.py

Test case:

  • scroll down until source code with "from"-section,
  • swype right,
  • swype down,
  • then radiply(!) swype left.

Hope it helps.

Flags: needinfo?(haswellready)
Attached file about-support.txt

Thanks @haswellready.

@lsalzman: Looks like this doesn't happen with Webrender.

No longer blocks: gfx-triage

Rares - can you see if someone on the mobile team can repro?

Flags: needinfo?(rares.doghi)

Hi, @Jessie I discussed with Rares and I will take a look at this bug.
I will update here once I will have the results regarding this issue.

Flags: needinfo?(rares.doghi) → needinfo?(andrei.bodea)

I checked this issue on the latest Nightly build from 7/20 GV 80 with Google Pixel 4 XL (android 11) with Webrender but I couldn't reproduce this issue.
@haswellready: Can you still reproduce this on latest nightly?
I will let my NI until further notice or until we will close this issue.

Flags: needinfo?(haswellready)

Still reproducible on my side on the latest nightly build 22010617 on Android 10, Honor 20 Pro.
I dont know how to see my Web renderer.

Flags: needinfo?(haswellready)

Could someone check It using emulator?

This is only reproducible on non-webrender and we are working on adding Webrender Mali-G7x support in the near future, which should fix this issue.

Blocks: not-wr
No longer blocks: wr-android
Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Depends on: wr-mali
Flags: needinfo?(andrei.bodea)
Resolution: --- → FIXED
Summary: Text becomes blurred when moving a page → non-WR/Mali-G76: Text becomes blurred when moving a page
You need to log in before you can comment on or make changes to this bug.