Closed Bug 164948 Opened 22 years ago Closed 22 years ago

Installed new version, hosed associations

Categories

(Core Graveyard :: File Handling, defect)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 131106

People

(Reporter: jamison, Assigned: dveditz)

Details

Ok, so I downloaded Mozilla 1.1 and now my file asociations are completely
screwed up.

After installing, doubleclicking an HTML file opened the page in Netscape 4
(previously set to Mozilla 1.0), the "edit" property now opens in Mozilla's html
editor (previously set to notepad), double clicking GIFs or JPEGs opens them in
Microsoft Photo Editor (previously they opened with IE)

Please fix this ****. I'm really sick of our products changing every setting on
my computer. I'm now going to spend the next half hour getting it back to the
way I had it so I can get some work done for the launch.
not installer
Component: Installer → File Handling
Henrik, how is it not installer?  Who owns the code that changes all the
associations if you select mozilla to be your default _browser_ (why not fix the
prompt at least to say browser/image viewer/editor so people know what they're
getting into??)?  If it's Bill Law then it needs a new owner.

We keep getting bug reports on this and I agree that the state of things is
ridiculous.
Status: UNCONFIRMED → NEW
Component: File Handling → Installer
Ever confirmed: true

*** This bug has been marked as a duplicate of 131106 ***
Status: NEW → RESOLVED
Closed: 22 years ago
Component: Installer → File Handling
Resolution: --- → DUPLICATE
bz: it's not the installer because the browser sets these. This is because of
the browser wars, where IE and Netscape each try to claim defaultness from the
other. If it were done only by the installer then the rival could be installed
later and steal your default setting. So IE, Navigator, Mozilla etc. all check
each time they start up and helpfully offer to be made the default if they are not.

Insane, but as long as that situation exists there was no need to go to any
trouble in the installer.
v
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → gbush
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.