Closed Bug 1649629 Opened 2 years ago Closed 2 years ago

Large inbox (68k messages) not shown/downloaded

Categories

(MailNews Core :: Networking: IMAP, defect)

defect

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: mastervanleeuwen, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [tls1.2 required])

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36

Steps to reproduce:

I have a large inbox (68k messages) which is not shown properly; this stopped working when I switched from stable version 68 to 78b03.
At first, I saw all the headers correctly, but when selecting a message, it does not appear. The status bar at the bottom of the window shows: 'Connected to <imap server>'

Actual results:

I tried repairing the inbox file (under properties of the inbox) but that resulted in dropping all the headers and the same 'Connected to ..' message, but no apparent progress at downloading the headers/messages.

Expected results:

I would have expected to see all headers in the mail window and the content of the message when I select a header.

Keywords: regression
Summary: Large inbox not shown/downloaded → Large inbox (68k messages) not shown/downloaded

What do you see in tools > error console immediately after starting for any relevant messages?

Blocks: tb78found
Component: Untriaged → Networking: IMAP
Flags: needinfo?(mastervanleeuwen)
Product: Thunderbird → MailNews Core
Whiteboard: [datalossy]

I found the error below, but I don't think it is related. After clearing the error console and trying to load the inbox, no new errors seem to appear.

The status message at the bottom of the main window keeps saying 'Connnected to [imap server]' and does not seem to go beyond that (I think 'syncing Inbox' and/or 'downloading headers/messages' normally occur there as well.

Let me know if there is something else that I can check/try...

The following error message is recurring a few times:

[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19
loadSync resource://gre/modules/L10nRegistry.jsm:658
fetchFile resource://gre/modules/L10nRegistry.jsm:573
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
map self-hosted:240
generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
InterpretGeneratorResume self-hosted:1151
next self-hosted:1099
generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
InterpretGeneratorResume self-hosted:1151
next self-hosted:1099
touchNext resource://gre/modules/Localization.jsm:167
regenerateBundles resource://gre/modules/Localization.jsm:552
activate resource://gre/modules/Localization.jsm:243
<anonymous> chrome://messenger/content/mailWidgets.js:37
<anonymous> chrome://messenger/content/customElements.js:34
<anonymous> chrome://messenger/content/customElements.js:37
observe resource://gre/modules/MailGlue.jsm:198

but I doubt that it is related...

Flags: needinfo?(mastervanleeuwen)

I thought to try and remove and re-add the e-mail account to see whether that works. Unfortunately, it does allow me to re-add, but now I do get some error messages in the error_log, at first with this:

18:19:00.272 2020-07-08 18:19:00 mail.setup INFO verify config:
Incoming: imap, imap.cern.ch:993, SSL, auth: plain, username: *****, password: set
Outgoing: Use existing server smtp4
2
18:19:00.274 2020-07-08 18:19:00 mail.setup INFO Setting incoming server authMethod to 3
2
18:19:00.275 2020-07-08 18:19:00 mail.setup INFO verifyLogon for server at imap.cern.ch
4
18:19:00.800 2020-07-08 18:19:00 mail.setup WARN error Unable to log in at server. Probably wrong configuration, username or password.
2
18:23:57.686 2020-07-08 18:23:57 mail.setup INFO manual config to test:
Incoming: imap, imap.cern.ch:993, SSL, auth: plain, username: *****, password: set
Outgoing: smtp, smtp.cern.ch:587, STARTTLS, auth: plain, username: *****, password: set

I triple-checked my password, so that cannot be the problem. Then when I keep fiddling with the settings, I get:
18:28:24.465 2020-07-08 18:28:24 mail.setup INFO status msg: Looking up configuration: Probing server
2
18:28:24.465 2020-07-08 18:28:24 mail.setup INFO switching to UI mode manual-edit-testing
2
18:28:24.469 2020-07-08 18:28:24 mail.setup INFO progress callback host imap.cern.ch port 993 type imap
2
18:28:24.469 2020-07-08 18:28:24 mail.setup INFO progress callback host smtp.cern.ch port 587 type smtp
2
18:28:25.695 2020-07-08 18:28:25 mail.setup INFO progress callback host smtp.cern.ch port 587 type smtp
2
18:28:25.696 2020-07-08 18:28:25 mail.setup INFO CHOOSING smtp smtp.cern.ch:587, auth method 5 6,3, SSL 3
2
18:28:25.696 2020-07-08 18:28:25 mail.setup INFO progress callback host smtp.cern.ch port 587 type smtp
2
18:28:25.718 2020-07-08 18:28:25 mail.setup INFO progress callback host imap.cern.ch port 993 type imap
2
18:28:25.718 2020-07-08 18:28:25 mail.setup INFO guessConfig failed: Can't find a server
2
18:28:25.718 2020-07-08 18:28:25 mail.setup WARN status error failed_to_find_settings
2
18:28:25.718 2020-07-08 18:28:25 mail.setup INFO status msg: Thunderbird failed to find the settings for your email account.

which is strange, because 1) the server exists and 2) I have explicitly specified all the settings (port number, authentication). Is there a way to check the connectivity to the 993 port from the command line?

Yes,
openssl s_client -crlf -connect map.cern.ch:993

Thanks! I tried that and it works:

'''
openssl s_client -crlf -connect imap.cern.ch:993
CONNECTED(00000005)
depth=2 C = GB, ST = Greater Manchester, L = Salford, O = COMODO CA Limited, CN = COMODO RSA Certification Authority
verify return:1
.....
'''
so then I don't understand why I got the 'failed to find the settings' message....

It's the login (creds) that fail, not the connection.

After you connect you would do (for username foo, password bar)

1 LOGIN foo bar

However, the problem seems to be that it's using a certificate we no longer accept. Min verion was changed to TLS 1.2

nmap --script ssl-enum-ciphers -p 993 imap.cern.ch

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → INVALID
Whiteboard: [datalossy] → [tls1.2 required]

Apologies; I had not posted the full output. It continues with a lot of certificate verification stuff and ends with:

  • OK The Microsoft Exchange IMAP4 service is ready.

I tried the LOGIN command and it ends successfully:

1 LOGIN *** ****
1 OK LOGIN completed.

But Thunderbird still says: 'Thunderbird failed to find the settings for your email account'. The error console shows the same messages that we had earlier:

11:00:50.648 2020-07-09 11:00:50 mail.setup INFO progress callback host smtp.cern.ch port 587 type smtp
11:00:50.649 2020-07-09 11:00:50 mail.setup INFO progress callback host imap.cern.ch port 993 type imap
11:00:50.650 2020-07-09 11:00:50 mail.setup INFO guessConfig failed: Can't find a server
11:00:50.650 2020-07-09 11:00:50 mail.setup WARN status error failed_to_find_settings

You need to log in before you can comment on or make changes to this bug.