Closed Bug 1649640 Opened 2 years ago Closed 2 years ago

Crash in [@ wl_proxy_marshal_array_constructor_versioned | <name omitted> | libxul.so@0x1ed20e9 | __pthread_mutex_lock | firefox@0x4941b]

Categories

(Core :: Widget: Gtk, defect, P3)

78 Branch
defect

Tracking

()

RESOLVED DUPLICATE of bug 1641778

People

(Reporter: matt.fagnani, Unassigned)

References

(Blocks 1 open bug)

Details

Crash Data

This bug is for crash report bp-1a22d8f4-9235-46bb-9838-33d110200630.

Top 10 frames of crashing thread:

0 libwayland-client.so.0 wl_proxy_marshal_array_constructor_versioned src/wayland-client.c:734
1 libwayland-client.so.0 <name omitted> src/wayland-client.c:834
2 libxul.so libxul.so@0x1ed20e9 
3 libpthread.so.0 __pthread_mutex_lock /usr/src/debug/glibc-2.31.9000-582-gea04f02131/nptl/../nptl/pthread_mutex_lock.c:135
4 firefox firefox@0x4941b 
5 libxul.so libxul.so@0x1e853a7 
6 libxul.so libxul.so@0x3299fad 
7 libxul.so libxul.so@0x68704f7 
8 libxul.so libxul.so@0x3126faa 
9 libc.so.6 __clock_getres /usr/src/debug/glibc-2.31.9000-582-gea04f02131/time/../sysdeps/unix/sysv/linux/clock_getres.c:37

I was using firefox-78.0-1.fc33.x86_64 on Wayland in Fedora Rawhide in Plasma 5.19.2. I opened Help > Troubleshooting information and closed it. I clicked on the Bookmarks menu. Firefox crashed with a segmentation fault in wl_proxy_marshal_array_constructor_versioned at src/wayland-client.c:734 in libwayland-client-1.18.0-1.fc33.x86_64 which was
message = &proxy->object.interface->methods[opcode];
The crash address was 0x10 which might indicate an invalid pointer such as proxy.

Blocks: wayland
Priority: -- → P3
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1641778
You need to log in before you can comment on or make changes to this bug.