Closed Bug 1649676 Opened 1 year ago Closed 1 year ago

Disabling an @font-face font in macOS that’s used in a webpage crashes Firefox

Categories

(Core :: Graphics: WebRender, defect, P3)

80 Branch
x86_64
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- disabled
firefox80 --- verified
firefox81 --- verified

People

(Reporter: robin, Assigned: lsalzman)

References

(Blocks 1 open bug)

Details

(Keywords: crash)

Crash Data

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

  1. Load reduced testcase in Firefox on macOS
  2. Open FontBook app
  3. Right click on Zapfino and disable it

Actual results:

Firefox crash. See for example https://crash-stats.mozilla.org/report/index/fb010147-10d7-4133-b174-eac420200701

Expected results:

No crash, and the testcase should revert to the system default font. When Zapfino is directly specified without using an @font-face rule this is the case and there’s no crash.

Crash Signature: [@ core::option::expect_none_failed | wr_resource_updates_add_font_descriptor ]
OS: Unspecified → macOS
Hardware: Unspecified → x86_64

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Layout: Text and Fonts
Product: Firefox → Core

Doesn't seem to crash for me with webrender disabled; moving to WR component.

Component: Layout: Text and Fonts → Graphics: WebRender

And with WR enabled, it does reproduce (note that it crashes the whole browser, not just the tab).

Status: UNCONFIRMED → NEW
Ever confirmed: true

Oh, sorry, I thought I tested it in both modes otherwise I would have put a WR label on it, must have not restarted the browser or something. And yes, it’s whole-browser crash, not tab.

Reproduces on Mac on central cc7eafcda.

Blocks: wr-mac
Severity: -- → S3
Flags: needinfo?(lsalzman)
Keywords: crash
Priority: -- → P3
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f25c770ccbf3
use fallback font if loading WR mac font descriptor fails. r=jfkthame
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Flags: needinfo?(lsalzman)
Flags: qe-verify+

Successfully reproduced the issue on Firefox Nightly (2020-06-30) under macOS 10.15.6 by following the STR from Comment 0.

The issue is fixed on Firefox 80.0b7 (webrender manually activated) and on Firefox Nightly 81.0a1 (2020-08-13).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.