Closed Bug 1649923 Opened 2 years ago Closed 2 years ago

Crash in [@ shutdownhang | mozilla::TaskController::GetRunnableForMTTask]

Categories

(Core :: XPCOM, defect)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1633342
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox77 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected

People

(Reporter: RyanVM, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-3918ffb6-3166-496f-86d4-bb8da0200701.

Top 10 frames of crashing thread:

0 ntdll.dll NtWaitForAlertByThreadId 
1 ntdll.dll RtlSleepConditionVariableSRW 
2 kernelbase.dll SleepConditionVariableSRW 
3 mozglue.dll mozilla::detail::ConditionVariableImpl::wait mozglue/misc/ConditionVariable_windows.cpp:50
4 xul.dll mozilla::TaskController::GetRunnableForMTTask xpcom/threads/TaskController.cpp:242
5 xul.dll nsThread::ProcessNextEvent xpcom/threads/nsThread.cpp:1148
6 xul.dll NS_ProcessNextEvent xpcom/threads/nsThreadUtils.cpp:513
7 xul.dll mozilla::net::nsHttpConnectionMgr::Shutdown netwerk/protocol/http/nsHttpConnectionMgr.cpp:245
8 xul.dll mozilla::net::nsHttpHandler::ShutdownConnectionManager netwerk/protocol/http/nsHttpHandler.cpp:2736
9 xul.dll mozilla::net::nsHttpHandler::Observe netwerk/protocol/http/nsHttpHandler.cpp:2283
Flags: needinfo?(bas)

This is interesting, it seems like we're force spinning an event loop waiting for something, but when that something has occurred we don't actually do anything to wake up the main thread.

This looks like it's simply the 'new' version of bug 1633342.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(bas)
Resolution: --- → DUPLICATE
Duplicate of bug: 1633342
You need to log in before you can comment on or make changes to this bug.