Closed Bug 1650033 Opened 3 months ago Closed 3 months ago

Diners Club logo is not detect when submit a credit card using a Diners Club CC number

Categories

(Toolkit :: Form Autofill, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox80 --- verified

People

(Reporter: alin.ilea, Assigned: zbraniecki)

References

(Blocks 1 open bug)

Details

(Whiteboard: [cc-autofill-mvp])

Attachments

(2 files)

Affected version:

All - if CC specific prefs are enabled.

Tested on:

Windows 10
Ubuntu 18.04

Steps to reproduce:

  1. Submit a credit card (CC) form with a Diners Club card number e.g. 30569309025904 or 38520000023237.
  2. Choose to save the Credit Card in the Save CC doorhanger.
  3. Open the list of saved cards in preferences.

Expected results:

Diners Club logo is displayed beside the card.

Actual results:

No logo is displayed beside the card.

Note:

When submitting a Mastercard credit card, the Diners Club logo is displayed instead of Mastecard logo. The Diners Club logo displayed in the attached screenshot its actually a Mastercard saved credit card. (Bug 1649028)

Whiteboard: cc-autofill-mvp → [cc-autofill-mvp]
Severity: -- → S4
Priority: -- → P2

Note -- the issue is that these cards are 14 digits long, while the card network detection code is expecting them to be 16.

Assignee: nobody → gandalf
Status: NEW → ASSIGNED

I verified against https://www.freeformatter.com/credit-card-number-generator-validator.html and extended the support to ranges as per Wikipedia plus a wider range for Diners.

I'm fairly okay with a wider net of types, since the card still has to match Luhn algorithm and in the worst case we're recognize a card of length that is not supported, but matches the prefix of IIN.

I also changed length property name to len because I find it confusing that range.length is a property of an object but also of a regular Array :) Hope it's ok!

Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2faa1e31dee0
Support length ranges in credit card IINs. r=abr
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

Verified - Fixed in latest Nightly 80.0a1 (build id: 20200711215253). Diners Club logo is displayed in the Saved Credit Cards after submitting a new Diners Club card.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.