Closed Bug 165080 Opened 18 years ago Closed 18 years ago

Delete product fails with missing column error

Categories

(Bugzilla :: Administration, task)

2.17
x86
Windows 2000
task
Not set
major

Tracking

()

RESOLVED FIXED
Bugzilla 2.18

People

(Reporter: james, Assigned: bbaetz)

Details

(Keywords: regression)

Attachments

(1 file)

Using 13/8/2002 CVS snapshot of Bugzilla on Win32 (installation was upgraded
from Bugzilla 2.14.2), when deleting a component 2 errors are generated relating
to the missing column 'product_id' in products.

This is because 'product_id' appears to have been renamed to 'id'.

Correcting the SQL generated on lines ~637 and ~420 corrects the error.
mine
Assignee: justdave → bbaetz
Keywords: patch, regression, review
Target Milestone: --- → Bugzilla 2.18
Attached patch patchSplinter Review
Patch looks good for me (must find diff for Win32...sigh...)
Comment on attachment 96962 [details] [diff] [review]
patch

2xr=joel
Attachment #96962 - Flags: review+
Checked in
Status: NEW → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.