Closed Bug 1650871 Opened 4 years ago Closed 4 years ago

Add all desktop pageload tests to browsertime

Categories

(Testing :: Performance, task, P1)

task

Tracking

(firefox80 fixed)

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: sparky, Assigned: sparky)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

This bug is for adding all tests to browsertime, it does not include enabling them in production.

This patch adds an option to disable the firefox window recorder in browsertime, it also adds it to the browsertime-mobile taskcluster config since it is disabled there (but not on desktop).

This patch adds all desktop pageload tests to browsertime. It adds taskcluster tasks for these but doesn't enable them in production. They can only be run when --full is used.

Depends on D82431

Status: NEW → ASSIGNED
Pushed by gmierz2@outlook.com:
https://hg.mozilla.org/integration/autoland/rev/9eda9113122d
Add option to disable firefox window recorder. r=perftest-reviewers,AlexandruIonescu
https://hg.mozilla.org/integration/autoland/rev/c90d36eecc9e
Add all browsertime desktop tests. r=perftest-reviewers,AlexandruIonescu
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Regressions: 1652086
You need to log in before you can comment on or make changes to this bug.