Closed Bug 1650880 Opened 1 year ago Closed 1 year ago

Alias from webExtensions only work on install, not subsequent browser restarts

Categories

(Firefox :: Search, defect, P4)

defect

Tracking

()

RESOLVED FIXED
Firefox 80
Iteration:
80.2 - July 13 - July 26
Tracking Status
firefox80 --- fixed

People

(Reporter: daleharvey, Assigned: daleharvey)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

We dont store the alias in the cache so dont restore it when reloading engines from cache

Blocks: search-alias
Duplicate of this bug: 1653258
Assignee: nobody → dharvey
Iteration: --- → 80.2 - July 13 - July 26
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0fb59851d956
Persist the engines alias in cache. r=Standard8
https://hg.mozilla.org/integration/autoland/rev/103d388bac74
Refactor toJSON in SearchEngine.jsm. r=Standard8

Ok the logs make it look like a race cache which would explain why its intermittent, updated to avoid that and looks like I cant see the error from a whole bunch of runs @ https://treeherder.mozilla.org/#/jobs?repo=try&revision=e7f401fe7b05bc90216a73a3deea467fe454510d

Flags: needinfo?(dharvey)
Pushed by dharvey@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/dad0085e266d
Persist the engines alias in cache. r=Standard8
https://hg.mozilla.org/integration/autoland/rev/229757cf5a2d
Refactor toJSON in SearchEngine.jsm. r=Standard8
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80
You need to log in before you can comment on or make changes to this bug.