Closed Bug 1651330 Opened 10 months ago Closed 9 months ago

Add Ubuntu's distribution configuration to the modern search engine configuration

Categories

(Firefox :: Search, task, P1)

task
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 80
Iteration:
80.2 - July 13 - July 26
Tracking Status
firefox-esr78 --- verified
firefox79 --- verified
firefox80 --- verified

People

(Reporter: standard8, Assigned: standard8)

References

Details

Attachments

(1 file)

Similar to bug 1630980, we want to add Ubuntu's codes to the modern search configuration. With the modern configuration, the distribution engines, codes etc are defined in the search engine configuration itself rather than via the distribution.ini/searchplugins.

This will apply to canonical, canonical-001 and canonical-002 distribution ids.

Adrian, the updated configuration is now on production on main-preview.

I think the main points to test are:

  • The new configuration is applied correctly.
  • Spot check that the codes for the changed engines are correct when the distribution isn't applied.
Flags: needinfo?(aflorinescu)

test-run in progress here.

In addition with the test run from comment 3, we have also did spot checks of the search codes as listed in the Search-Helper addon / changes for the required distribution-ids(ubuntu, ubuntu-001, ubuntu-002) + a bogus one(ubuntu-004), while also confirming the default non-distribution codes would still work properly.

The above tests were conducted on Windows 10 & Ubuntu 20. (although as the name suggests, the distribution codes would apply only to ubuntu distros, we approach it as a search-config update).

All looks good, no issues found.

Flags: needinfo?(adrian.florinescu) → needinfo?(dharvey)
Flags: needinfo?(dharvey) → needinfo?(standard8)
Iteration: 80.1 - June 29 - July 12 → 80.2 - July 13 - July 26
Flags: needinfo?(standard8)

The configuration is now live. It looks like we just missed the normal update for the repositories, so I'll update the patch with the new config.

Attachment #9162236 - Attachment description: Bug 1651330 - Include Canonical distribution in search engine configuration. (WIP). → Bug 1651330 - Include Canonical distribution in search engine configuration. r?mkaply

Comment on attachment 9162236 [details]
Bug 1651330 - Include Canonical distribution in search engine configuration. r?mkaply

Beta/Release Uplift Approval Request

  • User impact if declined: This is to land a remote settings change that was approved today in the tree. Normally this is done automatically, but given this is RC week I have taken the update and applied it in this patch.

The patch also includes an automated test.

The changes have already been tested on production preview by QA before the remote settings change was approved.

We would like to ensure it is in the 79 build source so that Ubuntu can use it fully in their builds.

  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Low risk, extends the search engine configuration only for the Canonical distribution ids, the configuration has various automated tests including for distribution, and QA have already tested.
  • String changes made/needed: None
Attachment #9162236 - Flags: approval-mozilla-beta?

(In reply to Mark Banner (:standard8) from comment #6)

  • User impact if declined: This is to land a remote settings change that was approved today in the tree. Normally this is done automatically, but given this is RC week I have taken the update and applied it in this patch.

I should have said: normally remote settings updates are landed twice a week - Monday & Thursday. We just missed today's landing.

Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3955a09f040c
Include Canonical distribution in search engine configuration. r=mkaply

Comment on attachment 9162236 [details]
Bug 1651330 - Include Canonical distribution in search engine configuration. r?mkaply

Approved for 79.0rc1.

Attachment #9162236 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment on attachment 9162236 [details]
Bug 1651330 - Include Canonical distribution in search engine configuration. r?mkaply

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: I also meant to ask for this on ESR. See above comments for details.
  • User impact if declined:
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String or UUID changes made by this patch:
Attachment #9162236 - Flags: approval-mozilla-esr78?

Comment on attachment 9162236 [details]
Bug 1651330 - Include Canonical distribution in search engine configuration. r?mkaply

Approved for 78.1esr.

Attachment #9162236 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 80

Adding to comment 4, tests were conducted using 79.0b8 and 79.0b9 with main-preview. Updating flags for 79, leaving a NI for spot-checking on Nightly Post-Modernization 80 test-run + spot-checking when the ESR hits candidate.

Flags: needinfo?(adrian.florinescu)

Marking this as verified on 80.0a1 based on test results - ran on Ubuntu 20 and Windows 10.
Additionally, verified as fixed on 78.1.0esr using Windows 10 64bit and Ubuntu 20, confirming the search-modernization config change works as expected when using the distributions codes.

As a side-note, the tests were performed using a simulated distribution (just the distribution.ini with the distribution id), since the distribution.ini preferences would force the locale based on the OS locale ( intl.locale.requested = "" preference)

Status: RESOLVED → VERIFIED
Flags: needinfo?(adrian.florinescu)
You need to log in before you can comment on or make changes to this bug.