Closed Bug 1651622 Opened 5 months ago Closed 4 months ago

[OSX 10.12] Crash in [@ _pthread_tsd_cleanup]

Categories

(Core :: Widget: Cocoa, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 + verified

People

(Reporter: jcristau, Assigned: keeler)

References

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-678ef981-a055-4140-a6f1-e3de80200709.

Top 7 frames of crashing thread:

0  @0x12e1b8ee0 
1 libsystem_pthread.dylib _pthread_tsd_cleanup 
2 libsystem_pthread.dylib _pthread_exit 
3 libsystem_pthread.dylib _pthread_body 
4 libsystem_pthread.dylib _pthread_start 
5 libsystem_pthread.dylib thread_start 
6 libnss3.dylib libnss3.dylib@0x11dc8f 

Seeing this signature spike up in nightly in the last day or two, on macos 10.12.

Specifically this seems to have started in 80.0a1 buildid 20200707094747.

I can see this crash constantly happening on macOS 10.12 with Firefox Nightly 80.0a1 (20200714083249) just by restarting Firefox. If Firefox is opened with a new profile it starts crashing after a second restart or normal close.

Flags: needinfo?(dkeeler)
Summary: Crash in [@ _pthread_tsd_cleanup] → [OSX 10.12] Crash in [@ _pthread_tsd_cleanup]

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #3)

Dana, is this from bug 1649518?

Looks like it. Unfortunately I don't have a 10.12 machine. Alexandru, can you reproduce this with the environment variable RUST_LOG set to osclientcerts_static=debug and attach the output? Thanks!

Flags: needinfo?(dkeeler) → needinfo?(alexandru.trif)
Attached file console.txt

Looks like it. Unfortunately I don't have a 10.12 machine. Alexandru, can you reproduce this with the environment variable RUST_LOG set to osclientcerts_static=debug and attach the output? Thanks!

I see this message when the crash reporter is presented:
[DEBUG osclientcerts_static] C_CloseAllSessions: CKR_OK [DEBUG osclientcerts_static::manager] ManagerArguments::Stop received - stopping Manager thread. [DEBUG osclientcerts_static] C_Finalize: CKR_OK

I hope this helps! If more information is needed please let me know.

Flags: needinfo?(alexandru.trif)

The severity field is not set for this bug.
:spohl, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(spohl.mozilla.bugs)

Assigning to Dana to match the assignee on bug 1654117.

Assignee: nobody → dkeeler
Severity: -- → S2
Flags: needinfo?(spohl.mozilla.bugs)
Priority: -- → P1

Seems to be fixed by bug 1654117.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80

I can confirm that this bug is fixed on macOS 10.12, starting with the 2020-07-25-09-40-10-mozilla-central nightly.

Status: RESOLVED → VERIFIED

I can no longer reproduce the crash on macOS 10.12 with Firefox 80.0b6(20200807195315) while restarting or closing Firefox as stated in comment 2.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.