Closed Bug 1651680 Opened 7 months ago Closed 6 months ago

mingw-w64-clang builds are broken with --enable-strip and not setting it increases .exe size by about 66%

Categories

(Firefox Build System :: General: Unsupported Platforms, defect)

78 Branch
defect

Tracking

(firefox-esr68 unaffected, firefox-esr7880+ fixed, firefox78 wontfix, firefox79 wontfix, firefox80 wontfix, firefox81 fixed)

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 80+ fixed
firefox78 --- wontfix
firefox79 --- wontfix
firefox80 --- wontfix
firefox81 --- fixed

People

(Reporter: gk, Assigned: glandium)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: in-triage, regression)

Attachments

(2 files)

While preparing our toolchain updates for Firefox 78 ESR. I realized that --enable-strip is gone for Windows and the build now breaks with that configure option set. However, we used it to cut down the size of our Tor Browser .exe files that way. Not setting that option anymore seems to increase the size by about 66%, which is excessive for bundles we want to ship, while e.g. on Linux just an 8% increase compared to Firefox 68 ESR-based bundles can be seen (the 8% are kind of not unusual).

The actual failure with --enable-strip looks like:

 0:08.12   File "/var/tmp/build/firefox-e2c9144979c2/configure.py", line 181, in <module>
 0:08.12     sys.exit(main(sys.argv))
 0:08.12   File "/var/tmp/build/firefox-e2c9144979c2/configure.py", line 52, in main
 0:08.12     sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure'))
 0:08.12   File "/var/tmp/build/firefox-e2c9144979c2/python/mozbuild/mozbuild/configure/__init__.py", line 455, in run
 0:08.12     self._value_for(option)
 0:08.12   File "/var/tmp/build/firefox-e2c9144979c2/python/mozbuild/mozbuild/configure/__init__.py", line 545, in _value_for
 0:08.12     return self._value_for_option(obj)
 0:08.12   File "/var/tmp/build/firefox-e2c9144979c2/python/mozbuild/mozbuild/util.py", line 1018, in method_call
 0:08.12     cache[args] = self.func(instance, *args)
 0:08.12   File "/var/tmp/build/firefox-e2c9144979c2/python/mozbuild/mozbuild/configure/__init__.py", line 613, in _value_for_option
 0:08.12     % option_string.split('=', 1)[0])
 0:08.12 mozbuild.configure.options.InvalidOptionError: --enable-strip is not available in this configuration
 0:08.19 *** Fix above errors and then restart with\
 0:08.19                "./mach build"
 0:08.19 make: *** [client.mk:115: configure] Error 1
Severity: -- → S3
Keywords: in-triage
Priority: -- → P3

This is due to bug 1639815, and I assume, this line in particular.

glandium, is the exclusion of Windows intentional here? Is there a significant amount of work required to allow Windows to set --enable-strip?

Flags: needinfo?(mh+mozilla)

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: General → General: Unsupported Platforms

The component has been changed since the backlog priority was decided, so we're resetting it.
For more information, please visit auto_nag documentation.

Priority: P3 → --
Assignee: nobody → mh+mozilla
Status: NEW → ASSIGNED
Flags: needinfo?(mh+mozilla)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/13a881966dda
Replace PKG_SKIP_STRIP with PKG_STRIP. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/09a5f4dcd92a
Support --enable-strip/--enable-install-strip on mingw. r=nalexander
Flags: needinfo?(mh+mozilla)
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/aafba1319774
Replace PKG_SKIP_STRIP with PKG_STRIP. r=nalexander
https://hg.mozilla.org/integration/autoland/rev/0ecdc8f7b354
Support --enable-strip/--enable-install-strip on mingw. r=nalexander
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch

Thanks glandium! Do you feel that's okay to have this backported to ESR78? If so, could you file the respective request? That would help us by having to ship two patches less in our pile of already existing patches. Thanks!

Flags: needinfo?(mh+mozilla)
Regressions: 1658632

Comment on attachment 9169320 [details]
Bug 1651680 - Replace PKG_SKIP_STRIP with PKG_STRIP.

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Fixes a build regression on TOR builds on esr78.
  • User impact if declined:
  • Fix Landed on Version:
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Practically speaking, this is a no-op for builds other than mingw.
  • String or UUID changes made by this patch:
Flags: needinfo?(mh+mozilla)
Attachment #9169320 - Flags: approval-mozilla-esr78?
Attachment #9169321 - Flags: approval-mozilla-esr78?

Comment on attachment 9169320 [details]
Bug 1651680 - Replace PKG_SKIP_STRIP with PKG_STRIP.

Makes life better for our Tor friends. Approved for 78.2esr.

Attachment #9169320 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
Attachment #9169321 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
You need to log in before you can comment on or make changes to this bug.