Closed Bug 1652685 Opened 1 year ago Closed 1 year ago

Inline IsPackedArray in CacheIR and Warp

Categories

(Core :: JavaScript Engine: JIT, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla80
Tracking Status
firefox80 --- fixed

People

(Reporter: jandem, Assigned: jandem)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

We can do this pretty easily after bug 1651645 removed the TI dependency. A first step would be making Ion's MIsPackedArray more robust/complete so we can use it in Warp.

Severity: normal → N/A
Priority: -- → P2

This makes it easier to reuse in Warp and makes the optimization more resillient
(fixes bug 1383643).

Duplicate of this bug: 1383643
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/591ba1c5748f
part 1 - Make MIsPackedArray not depend on TI for is-array and is-packed checks. r=anba
https://hg.mozilla.org/integration/autoland/rev/cde69ddc0296
part 2 - Move IsPackedArray code into the MacroAssembler. r=anba
https://hg.mozilla.org/integration/autoland/rev/b32115de87fc
part 3 - Optimize IsPackedArray in CacheIR and Warp. r=anba
You need to log in before you can comment on or make changes to this bug.