Closed Bug 1652785 Opened 1 year ago Closed 1 year ago

Show websites loaded in process in about:processes (title, favicon)

Categories

(Core :: DOM: Content Processes, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
82 Branch
Fission Milestone M6c
Tracking Status
firefox82 --- fixed

People

(Reporter: mossop, Assigned: Yoric)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

Attachments

(2 files)

It would be nice to be able to see the websites loaded in a given process in about:processes.

With Fission-enabled, about:processes shows the PID and the URL loaded in that process. Is there something else you were looking for?

Severity: -- → S3

(In reply to Neha Kochar [:neha] from comment #1)

With Fission-enabled, about:processes shows the PID and the URL loaded in that process. Is there something else you were looking for?

@ mossop ^

Depends on: about:processes
Flags: needinfo?(dtownsend)

Sort of, though inner-frames show up there with no obvious way of tying those to the site that loaded them.

Flags: needinfo?(dtownsend)

This will probably be needed for bug 1656383, too.

No longer depends on: about:processes
Summary: Show websites loaded in process in about:processes → Show websites loaded in process in about:processes (title, favicon)
Assignee: nobody → dteller
Status: NEW → ASSIGNED
Fission Milestone: --- → M6c
Priority: -- → P2
Duplicate of this bug: 1654329
Pushed by dteller@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efdd8cffde2b
Extract title, uri, window id for content processes;r=froydnj
https://hg.mozilla.org/integration/autoland/rev/7e71f3cff603
Display subframes, favicons;r=florian,fluent-reviewers,flod

Mmmh... if I read the log correctly, it's the previous test that fails, no?
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=314859887&repo=autoland&lineNumber=27501

Flags: needinfo?(dteller)

Ah, strike that, we still have timeouts in TV. It looks like we're hitting yet another race condition with tabs not being fully loaded by the time we check their title.

Actually, it's even worse, we're back to having "about:home" that doesn't always finish loading in TV.

Pushed by dteller@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ec8e1f8d7d7d
Extract title, uri, window id for content processes;r=froydnj
https://hg.mozilla.org/integration/autoland/rev/b8af21c6e678
Display subframes, favicons;r=florian,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Depends on: 1664468
Regressions: 1665099
Depends on: 1737439
You need to log in before you can comment on or make changes to this bug.