Closed Bug 1652830 Opened 1 year ago Closed 9 months ago

Update Test262 from the project's main branch

Categories

(Core :: JavaScript Engine, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
83 Branch
Tracking Status
firefox83 --- fixed

People

(Reporter: leonardo.balter, Assigned: leonardo.balter, NeedInfo)

References

Details

Attachments

(1 file, 1 obsolete file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36

Steps to reproduce:

Test262 is renaming its default branch from master to main.

https://github.com/tc39/test262/issues/2699

Actual results:

The master branch still exists but for a limited time. The test262 scripts reference the master branch.

Expected results:

Rename references from Test262's head branch from master to main.

Updates Test262 default's branch from master to main.

Ref https://github.com/tc39/test262/issues/2699

Everything is failing for me today, including a push w/ moz-phab (See https://bugzilla.mozilla.org/show_bug.cgi?id=1652855)

I uploaded a manually created patch file for now but I'll continue trying.

Flags: needinfo?(jorendorff)

Updates Test262 default's branch from master to main.

Ref https://github.com/tc39/test262/issues/2699

Assignee: nobody → leonardo.balter
Comment on attachment 9163607 [details] [diff] [review]
Bug 1652830 - Update Test262 default's branch. r?jorendorff

>diff --git a/js/src/tests/test/expected/import/files/local/smTempBranch/shell.js b/js/src/tests/test/expected/import/files/local/smTempBranch/shell.js
>index a75fdab20af1..ee1cf95742c7 100644
>--- a/js/src/tests/test/expected/import/files/local/smTempBranch/shell.js
>+++ b/js/src/tests/test/expected/import/files/local/smTempBranch/shell.js
>@@ -362,7 +362,7 @@ $ERROR = function $ERROR(message) {
> // License, v. 2.0. If a copy of the MPL was not distributed with this
> // file, You can obtain one at http://mozilla.org/MPL/2.0/.
> 
>-// https://github.com/tc39/test262/blob/master/INTERPRETING.md#host-defined-functions
>+// https://github.com/tc39/test262/blob/main/INTERPRETING.md#host-defined-functions
> ;(function createHostObject(global) {
>     var FunctionToString = global.Function.prototype.toString;
>     var ReflectApply = global.Reflect.apply;
>diff --git a/js/src/tests/test/run.py b/js/src/tests/test/run.py
>index 93f3915e76ce..76cf4e80a492 100755
>--- a/js/src/tests/test/run.py
>+++ b/js/src/tests/test/run.py
>@@ -1,5 +1,5 @@
> #!/usr/bin/env python
>-# Adapted from https://github.com/tc39/test262/blob/master/tools/generation/test/run.py
>+# Adapted from https://github.com/tc39/test262/blob/main/tools/generation/test/run.py
> 
> import shutil
> import subprocess
>diff --git a/js/src/tests/test262-export.py b/js/src/tests/test262-export.py
>index 4c180ed7e147..5bc1a038cb3d 100755
>--- a/js/src/tests/test262-export.py
>+++ b/js/src/tests/test262-export.py
>@@ -200,11 +200,11 @@ def cleanupMeta(meta):
>         # If the negative tag exists, phase needs to be present and set
>         if meta["negative"].get("phase") not in ("early", "runtime"):
>             print("Warning: the negative.phase is not properly set.\n" +
>-                  "Ref https://github.com/tc39/test262/blob/master/INTERPRETING.md#negative")
>+                  "Ref https://github.com/tc39/test262/blob/main/INTERPRETING.md#negative")
>         # If the negative tag exists, type is required
>         if "type" not in meta["negative"]:
>             print("Warning: the negative.type is not set.\n" +
>-                  "Ref https://github.com/tc39/test262/blob/master/INTERPRETING.md#negative")
>+                  "Ref https://github.com/tc39/test262/blob/main/INTERPRETING.md#negative")
> 
>     return meta
> 
>diff --git a/js/src/tests/test262-host.js b/js/src/tests/test262-host.js
>index 05617686ad8d..8b4fe89c8afb 100644
>--- a/js/src/tests/test262-host.js
>+++ b/js/src/tests/test262-host.js
>@@ -2,7 +2,7 @@
> // License, v. 2.0. If a copy of the MPL was not distributed with this
> // file, You can obtain one at http://mozilla.org/MPL/2.0/.
> 
>-// https://github.com/tc39/test262/blob/master/INTERPRETING.md#host-defined-functions
>+// https://github.com/tc39/test262/blob/main/INTERPRETING.md#host-defined-functions
> ;(function createHostObject(global) {
>     "use strict";
> 
>diff --git a/js/src/tests/test262-update.py b/js/src/tests/test262-update.py
>index 38a385f20754..a11fb78a872a 100755
>--- a/js/src/tests/test262-update.py
>+++ b/js/src/tests/test262-update.py
>@@ -75,7 +75,7 @@ def tryParseTestFile(test262parser, source, testName):
>     Returns the result of test262parser.parseTestRecord() or None if a parser
>     error occured.
> 
>-    See <https://github.com/tc39/test262/blob/master/INTERPRETING.md> for an
>+    See <https://github.com/tc39/test262/blob/main/INTERPRETING.md> for an
>     overview of the returned test attributes.
>     """
>     try:
>@@ -230,7 +230,7 @@ def convertTestFile(test262parser, testSource, testName, includeSet, strictTests
>     """
> 
>     # The test record dictionary, its contents are explained in depth at
>-    # <https://github.com/tc39/test262/blob/master/INTERPRETING.md>.
>+    # <https://github.com/tc39/test262/blob/main/INTERPRETING.md>.
>     testRec = tryParseTestFile(test262parser, testSource.decode("utf-8"), testName)
> 
>     # jsreftest meta data
>@@ -447,7 +447,7 @@ def process_test262(test262Dir, test262OutDir, strictTests, externManifests):
>                 continue
> 
>             # Files ending with "_FIXTURE.js" are fixture files:
>-            # https://github.com/tc39/test262/blob/master/INTERPRETING.md#modules
>+            # https://github.com/tc39/test262/blob/main/INTERPRETING.md#modules
>             isFixtureFile = fileName.endswith("_FIXTURE.js")
> 
>             # Read the original test source and preprocess it for the jstests harness.
>@@ -486,7 +486,7 @@ def fetch_local_changes(inDir, outDir, srcDir, strictTests):
>     """
>     import subprocess
> 
>-    # TOOD: fail if it's in the master branch? or require a branch name?
>+    # TODO: fail if it's in the default branch? or require a branch name?
> 
>     # Checks for unstaged or non committed files. A clean branch provides a clean status.
>     status = subprocess.check_output(
>@@ -505,26 +505,26 @@ def fetch_local_changes(inDir, outDir, srcDir, strictTests):
> 
>     # Fetches the file names to import
>     files = subprocess.check_output(
>-        ("git -C %s diff master --diff-filter=ACMR --name-only" % srcDir).split(" ")
>+        ("git -C %s diff main --diff-filter=ACMR --name-only" % srcDir).split(" ")
>     )
> 
>     # Fetches the deleted files to print an output log. This can be used to
>     # set up the skip list, if necessary.
>     deletedFiles = subprocess.check_output(
>-        ("git -C %s diff master --diff-filter=D --name-only" % srcDir).split(" ")
>+        ("git -C %s diff main --diff-filter=D --name-only" % srcDir).split(" ")
>     )
> 
>     # Fetches the modified files as well for logging to support maintenance
>     # in the skip list.
>     modifiedFiles = subprocess.check_output(
>-        ("git -C %s diff master --diff-filter=M --name-only" % srcDir).split(" ")
>+        ("git -C %s diff main --diff-filter=M --name-only" % srcDir).split(" ")
>     )
> 
>     # Fetches the renamed files for the same reason, this avoids duplicate
>     # tests if running the new local folder and the general imported Test262
>     # files.
>     renamedFiles = subprocess.check_output(
>-        ("git -C %s diff master --diff-filter=R --summary" % srcDir).split(" ")
>+        ("git -C %s diff main --diff-filter=R --summary" % srcDir).split(" ")
>     )
> 
>     # Print some friendly output
>@@ -723,7 +723,7 @@ if __name__ == "__main__":
>     parser = argparse.ArgumentParser(description="Update the test262 test suite.")
>     parser.add_argument("--url", default="git://github.com/tc39/test262.git",
>                         help="URL to git repository (default: %(default)s)")
>-    parser.add_argument("--branch", default="master",
>+    parser.add_argument("--branch", default="main",
>                         help="Git branch (default: %(default)s)")
>     parser.add_argument("--revision", default="HEAD",
>                         help="Git revision (default: %(default)s)")
Attachment #9163607 - Attachment is obsolete: true

There's a r+ patch which didn't land and no activity in this bug for 2 weeks.
:leonardo.balter, could you have a look please?
For more information, please visit auto_nag documentation.

Flags: needinfo?(leonardo.balter)
Duplicate of this bug: 1670507

Why haven't we landed this yet? Is it just that Leo didn't set checkin-needed on the patch, and no one noticed?

Yes.

Flags: needinfo?(jorendorff)
Pushed by jorendorff@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bf4db2372cba
Update Test262 default's branch. r=jorendorff,anba
Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
You need to log in before you can comment on or make changes to this bug.