Closed Bug 1652940 Opened 2 years ago Closed 2 years ago

Address book migration doesn't properly handle values in mail.server.*.whiteListAbURI

Categories

(MailNews Core :: Address Book, defect, P1)

Tracking

(thunderbird_esr78+ fixed, thunderbird79 fixed)

RESOLVED FIXED
Thunderbird 80.0
Tracking Status
thunderbird_esr78 + fixed
thunderbird79 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

The migrator as it is only updates the default setting for whiteListAbURI, and only the first matching URI. It should change all appropriate URIs for all servers, not just the default.

Actually it's worse than just the first matching URI. If there's more than one, it changes the start of the first and the end of the last.

Blocks: tb78found

This needs to happen soon, as it's one-time-only profile migration.

Attachment #9163738 - Flags: review?(paul)
Attachment #9163738 - Flags: approval-comm-beta?
Priority: -- → P1
Comment on attachment 9163738 [details] [diff] [review]
1652940-migration-whitelist-1.diff

Hmm, Paul's not here. Asking him to review this was silly.
Attachment #9163738 - Flags: review?(paul) → review?(alessandro)
Comment on attachment 9163738 [details] [diff] [review]
1652940-migration-whitelist-1.diff

Review of attachment 9163738 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good and everything seems to work when launching 78 with the profile coming from 68.
Attachment #9163738 - Flags: review?(alessandro) → review+

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/539e414d1316
Fix address book migration of mail.server.*.whiteListAbURI prefs. r=aleca DONTBUILD

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 80.0
Comment on attachment 9163738 [details] [diff] [review]
1652940-migration-whitelist-1.diff

Approved for beta
Attachment #9163738 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1655315

ESR uplift?

Comment on attachment 9163738 [details] [diff] [review]
1652940-migration-whitelist-1.diff

> ESR uplift?

Yeah, we'd better do that sooner rather than later.
Attachment #9163738 - Flags: approval-comm-esr78?
Comment on attachment 9163738 [details] [diff] [review]
1652940-migration-whitelist-1.diff

Approved for esr78
Attachment #9163738 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.