Closed Bug 1653335 Opened 7 months ago Closed 6 months ago

Remove MakeSpan and use constructors instead

Categories

(Core :: MFBT, task)

task

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox81 --- fixed

People

(Reporter: sg, Assigned: sg)

References

(Regressed 1 open bug)

Details

Attachments

(4 files)

No description provided.
Summary: Remove MakeSpan and uses constructors instead → Remove MakeSpan and use constructors instead
Attachment #9164090 - Attachment description: Bug 1653335 - Get rid off MakeSpan functions. r=froydnj → Bug 1653335 - Get rid of MakeSpan functions. r=froydnj
Pushed by sgiesecke@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ed0e07157cc7
Remove uses of MakeSpan in return statements. r=froydnj
https://hg.mozilla.org/integration/autoland/rev/692de25c4da9
Add/fix constructors and deduction guides for Span. r=froydnj
https://hg.mozilla.org/integration/autoland/rev/8082abc38fde
Replace MakeSpan uses by constructor calls. r=froydnj
https://hg.mozilla.org/integration/autoland/rev/47c65bafb45b
Get rid of MakeSpan functions. r=froydnj
Regressions: 1657963
Duplicate of this bug: 1601844
You need to log in before you can comment on or make changes to this bug.