Closed Bug 1653374 Opened 3 months ago Closed 3 months ago

sw-wr: black rectangles in upper right corner of page when scrolling

Categories

(Core :: Graphics: WebRender, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla80
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox78 --- unaffected
firefox79 --- unaffected
firefox80 --- verified

People

(Reporter: cpeterson, Assigned: lsalzman)

References

(Blocks 1 open bug, Regression, )

Details

(Keywords: regression)

Attachments

(3 files)

Attached image SW-WR_screenshot.png

Steps to reproduce

  1. Set gfx.webrender.all and gfx.webrender.software = true.
  2. Restart Nightly.
  3. Load https://www.bungie.net/en/Explore/Detail/News/49340
  4. Maximize the browser window to make the problem easier to see.
  5. Slowly scroll down and up the page.

result

The upper right corner of the page is not rendered. It appears to be covered by black rectangles. See the attached screenshot.

Disabling gfx.webrender.software makes the problem go away.

I've seen this problem on other pages but not all.

I bisected the regression to this pushlog that points to bug 1650984:

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=a05fbae74197b3e9e69f5e0003026451a82bf9cd&tochange=97f04a5dac7c6cb9daeb1e1d32f38111bb922891

Lee, this SW-WR bug is a regression from your SWGL compositor changes in bug 1650984.

Flags: needinfo?(lsalzman)

(In reply to Chris Peterson [:cpeterson] from comment #1)

Lee, this SW-WR bug is a regression from your SWGL compositor changes in bug 1650984.

Can you please post your about:support info?

Flags: needinfo?(lsalzman) → needinfo?(cpeterson)
Blocks: sw-wr
Severity: -- → S3
Priority: -- → P3
Attached file My about:support

I attached my about:support info.

Flags: needinfo?(cpeterson)
Assignee: nobody → lsalzman
Status: NEW → ASSIGNED
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b045b030ffcb
fix SwCompositor dependency tracking to account for transitive overlap dependencies. r=gw
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla80
Duplicate of this bug: 1653426
Flags: qe-verify+

Reproduced the issue using Firefox 80.0a1 (20200716212737) on Windows 10x64 and STR from comment 0.
The issue is verified fixed with Firefox 80.0b6(20200807195315) on Windows 10x64, macOS 10.12 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.