OCSP Error - Logins complain about "date in the future"

RESOLVED DUPLICATE of bug 158141

Status

NSS
Libraries
--
major
RESOLVED DUPLICATE of bug 158141
16 years ago
16 years ago

People

(Reporter: Grover Righter, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
OCSP Error - Logins complain about "date in the future"

When I attempt to Log into my bank and access my online banking, I receive an error that comes up in an Alert box:
"Error trying to validate certificate from online.MYBANK.com using OCSP - reponse contains a date which is in the future."

I am able to Log into this account using MSIE and OPERA. Also, I don't seem to have this bug on my Linux system running Mozilla.

Comment 1

16 years ago
on my build Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
WIN98SE i got the same, when trying to access the Link

https://app.miles-and-more.com/aerodyn/mm_main.aero?action=mm_account&l=de&pos=de&p=mmb

from the URL

http://www.miles-and-more.com/mam/de/de/homepage/  -> Quicklinks -> Meilenkonto

with these settings of OCSP (see milesandmore_settings.jpg)
unfortunately i did not check with other browsers at that moment...
instead, i reported it to their webmaster, but he did not have this my problem,
so i re-tried it today, and no more problem.

I suppose the alert box is filled with the wrong text, it should say "server
cannot be reached at the moment".

Best regards, Mario

Comment 2

16 years ago
Created attachment 98688 [details]
my OCSP settings

Comment 3

16 years ago
I am using
Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
and I am experiencing the same bug. All all https requests that use OCSP fail
with the above error. The problem ist definitely not with the website.
It is a particulatly annoying bug as it prevents these requests from working
unless you turn OCSP off completely (which is not why it's there...).

Comment 4

16 years ago
I encountered the same bug after enabling OCSP (it was disabled by default) on a
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
So I'd recommend setting "OS" to "All".
Perhaps anyone could try this out on a Mac?

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 158141 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 6

16 years ago
Adding CC, moving to NSS.
Severity: normal → major
Component: Security: General → Libraries
OS: Windows 2000 → All
Product: Browser → NSS
Hardware: PC → All
Version: other → unspecified
You need to log in before you can comment on or make changes to this bug.