Closed Bug 1653498 Opened 4 years ago Closed 4 years ago

Server-Timings not exposed for insecure connections in navigation timing

Categories

(Core :: Networking, defect)

78 Branch
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: bripkens, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_5) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/83.0.4103.116 Safari/537.36 Edg/83.0.478.56

Steps to reproduce:

Add a Server-Timing header to a navigation request's response via a plain HTTP connection.

Actual results:

The server timing entries are not exposed via navigation timings, i.e. performance.getEntriesByType('navigation')

Expected results:

The server timing entries should be exposed.

Hi bripkens,
I am marking this as an enhancement for now and moving it over to it's component so the developers can check this out.
Thanks for the report!

Status: UNCONFIRMED → NEW
Type: defect → enhancement
Component: Untriaged → Netmonitor
Ever confirmed: true
Product: Firefox → DevTools

Thanks for the report!
I'm able to i see the issue.

STR

  1. Open the net monitor.
  2. Go to https://uttermost-ringed-wavelength.glitch.me/dreams
  3. To filter request list, type dreams
  4. Select the request
  5. Go to the timings panel.
  6. The server timings should be visible
  7. Switch to http://uttermost-ringed-wavelength.glitch.me/dreams
  8. Repeat 3 - 5

AR:
The server timings do not show
performance.getEntriesByType('navigation') does not have server timings
ER:
The server timings should show
performance.getEntriesByType('navigation'). should have the server timings

Note: Chrome shows server timings for both http and https

This looks like a platform issue as the devtools does not get any server timings form the platform for http requests.
Moving to Networking.

Type: enhancement → defect
Component: Netmonitor → Networking
Product: DevTools → Core

(In reply to Hubert Boma Manilla (:bomsy) from comment #5)

This looks like a platform issue as the devtools does not get any server timings form the platform for http requests.
Moving to Networking.

Please see bug 1436517.
I think we don't want to support plain-text server timings.

Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.